# Filebeat does not create daily indices into elasticsearch automatically

**URL:** <https://discuss.elastic.co/t/filebeat-does-not-create-daily-indices-into-elasticsearch-automatically/83351>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 24, 2017, 3:19am UTC](https://discuss.elastic.co/t/filebeat-does-not-create-daily-indices-into-elasticsearch-automatically/83351 "2017-04-24T03:19:50Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![XiaozhongLiu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xiaozhongliu/32/17602_2.png) [@XiaozhongLiu](https://discuss.elastic.co/u/XiaozhongLiu)\
**Post date:** [April 24, 2017, 3:19am UTC](https://discuss.elastic.co/t/filebeat-does-not-create-daily-indices-into-elasticsearch-automatically/83351/1 "2017-04-24T03:19:50Z")

</div>

filebeat does not create daily indices into elasticsearch automatically.  
for example I have to manually create a indice like filebeat-2017.04.24, with this, filebeat can then auto harvest and dump logs.

if no indice is there today, the following error shows up:  
2017/04/24 02:58:07.022131 output.go:109: DBG output worker: publish 10 events  
2017/04/24 02:58:07.024207 client.go:658: INFO Connected to Elasticsearch version 5.3.0  
2017/04/24 02:58:07.024242 output.go:301: INFO Trying to load template for client: [http://localhost:9200](http://localhost:9200)  
2017/04/24 02:58:07.024668 output.go:322: INFO Template already exists and will not be overwritten.  
2017/04/24 02:58:07.026254 client.go:250: ERR Failed to perform any bulk index operations: 404 Not Found  
2017/04/24 02:58:07.026271 single.go:91: INFO Error publishing events (retrying): 404 Not Found  
2017/04/24 02:58:08.027925 client.go:658: INFO Connected to Elasticsearch version 5.3.0  
2017/04/24 02:58:08.027958 output.go:301: INFO Trying to load template for client: [http://localhost:9200](http://localhost:9200)  
2017/04/24 02:58:08.028454 output.go:322: INFO Template already exists and will not be overwritten.  
2017/04/24 02:58:08.030287 client.go:250: ERR Failed to perform any bulk index operations: 404 Not Found  
2017/04/24 02:58:08.030305 single.go:91: INFO Error publishing events (retrying): 404 Not Found

**stack & environment:**  
**filebeat =\> elasticsearch =\> kibana (with x-pack)**  
elasticsearch version 5.3.0  
filebeat version 5.3.1 (amd64), libbeat 5.3.1

**config:**  
 ![](https://us1.discourse-cdn.com/elastic/original/3X/2/c/2c4942d44ba563677aba075926e95c89435543e2.png)

 ![](https://us1.discourse-cdn.com/elastic/original/3X/c/6/c6da9d6c0640deefa78388e5a199beb5c05517c1.png)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 24, 2017, 3:22am UTC](https://discuss.elastic.co/t/filebeat-does-not-create-daily-indices-into-elasticsearch-automatically/83351/2 "2017-04-24T03:22:22Z")

</div>

What version of things are you using?  
What does your config look like?

---

<div class="post-metadata">

**Author:** ![XiaozhongLiu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xiaozhongliu/32/17602_2.png) [@XiaozhongLiu](https://discuss.elastic.co/u/XiaozhongLiu)\
**Post date:** [April 24, 2017, 3:48am UTC](https://discuss.elastic.co/t/filebeat-does-not-create-daily-indices-into-elasticsearch-automatically/83351/4 "2017-04-24T03:48:36Z")

</div>

Hi warkolm, thanks for ur reply, I revised the original post.

**[update: resolved]**  
the solution is to append ,filebeat\* to the action.auto\_create\_index option in elasticsearch.yml  
I recommend the editor to revise the following wiki to add a note or directly append filebeat and logstash for the convenience of future readers.  
[https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html](https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 24, 2017, 4:22am UTC](https://discuss.elastic.co/t/filebeat-does-not-create-daily-indices-into-elasticsearch-automatically/83351/5 "2017-04-24T04:22:18Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 22, 2017, 4:29am UTC](https://discuss.elastic.co/t/filebeat-does-not-create-daily-indices-into-elasticsearch-automatically/83351/6 "2017-05-22T04:29:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
