# FileBeat doesn't understand FQDN

**URL:** <https://discuss.elastic.co/t/filebeat-doesnt-understand-fqdn/298261>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 25, 2022, 10:03am UTC](https://discuss.elastic.co/t/filebeat-doesnt-understand-fqdn/298261 "2022-02-25T10:03:25Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![cawoodm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cawoodm/32/14083_2.png) [@cawoodm](https://discuss.elastic.co/u/cawoodm)\
**Post date:** [February 25, 2022, 10:03am UTC](https://discuss.elastic.co/t/filebeat-doesnt-understand-fqdn/298261/1 "2022-02-25T10:03:25Z")

</div>

There seems to be a bug in FileBeat under Windows where Filebeat ignores the domain and assumes it can try contact Kafka with just a hostname. This fails when the filebeat is running in a different domain and the host is not reachable

```nohighlight
output.kafka:
  hosts: ["server1.ourdomain.com:9093"]

```

The error is:

```auto
2022-02-25T10:29:29.583+0100	INFO	kafka/log.go:53	producer/broker/0 state change to [closing] because dial tcp: lookup server1: no such host

```

The workaround is to add the following to the `hosts` file:

```auto
<IP of server1> server1

```

After this it works. So the filebeat kafka filter seems to just remove `ourdomain.com` when it resolves the host.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 25, 2022, 12:04pm UTC](https://discuss.elastic.co/t/filebeat-doesnt-understand-fqdn/298261/2 "2022-03-25T12:04:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
