# Filebeat Error creating runner from config: failed to initialize condition

**URL:** https://discuss.elastic.co/t/filebeat-error-creating-runner-from-config-failed-to-initialize-condition/316351
**Category:** Beats
**Tags:** filebeat
**Created:** [October 11, 2022, 3:37pm UTC](https://discuss.elastic.co/t/filebeat-error-creating-runner-from-config-failed-to-initialize-condition/316351 "2022-10-11T15:37:39Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![juliana\_cg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juliana_cg/32/99127_2.png) [@juliana\_cg](https://discuss.elastic.co/u/juliana_cg)
#### Post date: [October 11, 2022, 3:37pm UTC](https://discuss.elastic.co/t/filebeat-error-creating-runner-from-config-failed-to-initialize-condition/316351/1 "2022-10-11T15:37:39Z")

</div>

Hello,

Got Filebeat installed as a daemonset in Kubernetes cluster, to collect logs from different pods using hint autodiscovery. On filebeat logs we have plenty of errors of this type:

```auto
ERROR [autodiscover] cfgfile/list.go:99 Error creating runner from config: failed to initialize condition: missing or invalid condition

```

Sometimes we find we are not getting any logs from certain pods and there is no apparent reason. We wonder if this error could be the cause, could you explain the meaning of this error?  
Our filebeat config looks like this:

```auto
data:
  filebeat.yml: |-
    filebeat.inputs:
    - type: log
      paths:
      - /var/log/kube-apiserver-audit.log
      fields:
        audit: true
      json:
        add_error_key: true
    - type: log
      paths:
      - /var/log/kube-apiserver.log
      - /var/log/kube-controller-manager.log
      - /var/log/kube-proxy.log
      - /var/log/kube-scheduler.log
      fields:
        system: true

    filebeat.autodiscover:
      providers:
      - type: kubernetes
        node: ${NODE_NAME}
        hints:
          enabled: true
          default_config.enabled: false
          default_config:
            type: container
            paths:
              - /var/log/containers/*-${data.kubernetes.container.id}.log
            close_inactive: 5m
        include_annotations:
        - elasticservice/cluster
        - elasticservice/index
        - elasticservice/pipeline
        add_resource_metadata:
          namespace:
            enabled: true

    logging:
      level: info
      metrics.enabled: false

    http:
      enabled: true
      host: localhost
      port: 5066

    processors:
    - drop_event:
        when:
          contains:
            kubernetes.namespace: "xxx"
    - drop_fields:
        when:
          has_fields: ['fields.audit']
        fields:
        - "json.requestObject.metadata.managedFields"
        - "json.responseObject.metadata.managedFields"
        ignore_missing: true
    - add_fields:
        target: ''
        fields:
          hosting:
            type: k8s
            name: elasticservice

    output.logstash:
      hosts:
      - logstash.elastic-prod.svc:5044

      pipelining: 0
      ttl: 2m
      worker: 4
      bulk_max_size: 2000
      slow_start: false

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 8, 2022, 5:38pm UTC](https://discuss.elastic.co/t/filebeat-error-creating-runner-from-config-failed-to-initialize-condition/316351/2 "2022-11-08T17:38:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
