# Filebeat error: Exiting: Error in initing input: the processor dissect doesn't exist

**URL:** <https://discuss.elastic.co/t/filebeat-error-exiting-error-in-initing-input-the-processor-dissect-doesnt-exist/262255>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 26, 2021, 4:16pm UTC](https://discuss.elastic.co/t/filebeat-error-exiting-error-in-initing-input-the-processor-dissect-doesnt-exist/262255 "2021-01-26T16:16:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![eeijlar](https://avatars.discourse-cdn.com/v4/letter/e/96bed5/32.png) [@eeijlar](https://discuss.elastic.co/u/eeijlar)\
**Post date:** [January 26, 2021, 4:16pm UTC](https://discuss.elastic.co/t/filebeat-error-exiting-error-in-initing-input-the-processor-dissect-doesnt-exist/262255/1 "2021-01-26T16:16:08Z")

</div>

I am getting this error when I start the filebeat container in kubernetes:

```auto
    2021-01-26T15:59:47.358Z INFO input/input.go:88 Starting input of type: log; ID: 11352026245999945754  
    2021-01-26T15:59:47.358Z INFO crawler/crawler.go:109 Stopping Crawler
    2021-01-26T15:59:47.358Z INFO crawler/crawler.go:119 Stopping 11 inputs
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 11352026245999945754
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 744136122161974921
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 12289493283275638369
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 7202071645634784033
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 6973522505320068178
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 12270853431453163321
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 4245240374096342379
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 18107116180478240089
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 4341488697707772042
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 9884316022712335150
    2021-01-26T15:59:47.358Z INFO input/input.go:122 input ticker stopped
    2021-01-26T15:59:47.358Z INFO input/input.go:139 Stopping Input: 9454966221385824952
    2021-01-26T15:59:47.358Z INFO crawler/crawler.go:135 Crawler stopped
    2021-01-26T15:59:47.358Z INFO registrar/registrar.go:247 Stopping Registrar
    2021-01-26T15:59:47.358Z INFO registrar/registrar.go:173 Ending Registrar
    2021-01-26T15:59:47.450Z INFO [monitoring] log/log.go:132 Total non-zero metrics {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":20,"time":{"ms":30}},"total":{"ticks":60,"time":{"ms":72},"value":60},"user":{"
    ticks":40,"time":{"ms":42}}},"info":{"ephemeral_id":"e43dfb6d-5728-4037-a259-c4cd59b5c24b","uptime":{"ms":491}},"memstats":{"gc_next":4194304,"memory_alloc":2178688,"memory_total":3978704,"rss":21807104}},"filebeat":{"harvester":{"open_
    files":0,"running":0}},"libbeat":{"config":{"module":{"running":0}},"output":{"type":"logstash"},"pipeline":{"clients":0,"events":{"active":0}}},"registrar":{"states":{"current":0},"writes":{"success":2,"total":2}},"system":{"cpu":{"cor
    es":8},"load":{"1":0.99,"15":0.29,"5":0.43,"norm":{"1":0.1238,"15":0.0363,"5":0.0538}}}}}}
    2021-01-26T15:59:47.450Z INFO [monitoring] log/log.go:133 Uptime: 493.39324ms
    2021-01-26T15:59:47.450Z INFO [monitoring] log/log.go:110 Stopping metrics logging.
    2021-01-26T15:59:47.450Z INFO instance/beat.go:321 filebeat stopped.
    2021-01-26T15:59:47.450Z ERROR instance/beat.go:691 Exiting: Error in initing input: the processor dissect doesn't exist
    Exiting: Error in initing input: the processor dissect doesn't exist

```

Is there anywhere I can look at to get more information on the error. The container doesn't start up. Is there any way to keep the container alive so I can get on and see what is going on?

I tried adding this to the values file but it doesn't make any difference:

```auto
  livenessProbe:
    exec:
      command:
        - bash
        - c
        - sleep infinity
  readinessProbe:
    exec:
      command:
        - bash
        - c
        - sleep infinity

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 23, 2021, 6:16pm UTC](https://discuss.elastic.co/t/filebeat-error-exiting-error-in-initing-input-the-processor-dissect-doesnt-exist/262255/2 "2021-02-23T18:16:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
