# Filebeat Error logstash/async.go:280 "client is not connected"

**URL:** https://discuss.elastic.co/t/filebeat-error-logstash-async-go-280-client-is-not-connected/308874
**Category:** Beats
**Tags:** filebeat
**Created:** [July 5, 2022, 9:02am UTC](https://discuss.elastic.co/t/filebeat-error-logstash-async-go-280-client-is-not-connected/308874 "2022-07-05T09:02:52Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Ricard-CT](https://avatars.discourse-cdn.com/v4/letter/r/74df32/32.png) [@Ricard-CT](https://discuss.elastic.co/u/Ricard-CT)
#### Post date: [July 5, 2022, 9:02am UTC](https://discuss.elastic.co/t/filebeat-error-logstash-async-go-280-client-is-not-connected/308874/1 "2022-07-05T09:02:52Z")

</div>

Hi,

I have installed ELK Stack in my server and all seems to work fine, but when filebeat (installed on another server) tries to send the log to Logstash, an error appears:

```auto
ERROR [logstash] logstash/async.go:280 Failed to publish events caused by: client is not connected

```

When I try to connect from the client server, where filebeat is installed using telnet XXX.XXX.XXX.XXX 5044 it works fine.

There is probably a mistake in my filebeat config but i can't see it:

```auto
filebeat.inputs:

-type: log

paths:
    - /var/log/httpd/access_log

filebeat.config.modules:
    path: ${path.config}/modules.d/*.yml
    reload.enabled: false

setup.kibana:
    host: "xxx.xxx.xxx.xxx:5601" #ELKServer IP

output.logstash:
     hosts: ["xxx.xxx.xxx.xxx:5044"] #ELKServer IP
     bulk_max_size: 1024

processors:
  - add_host_metadata:
      when.not.contains.tags: forwarded
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

```

Filebeat apache module config:

```auto
- module: apache
  access:
    enabled: true
    var.paths: ["/var/log/httpd/access_log"]

  error:
    enabled: false
    var.paths: ["/var/log/httpd/error_log"]

```

Also my logstash configuration:

```auto
path.data: /var/lib/logstash
path.logs: /var/log/logstash
http.port: 5044
http.host: 0.0.0.0

```

And my logstash input / output conf:

```auto
input {
  beats {
    port => 5044
  }
}

filter {
  if [event][module] == "apache" {
    if [fileset][name] == "access" {
      grok {
            match => ["message" => "%{COMBINEDAPACHELOG}"]
           }
    }
  }
}

output {
  elasticsearch {
    hosts => ["http://localhost:9200"]
    index => "%{[@metadata][beat]}-%{[@metadata][version]}"

  }
}

```

I really would appreciate your help. I have been looking for days and I can't find where the issue is.

Thanks in advance.

---

<div class="post-metadata">

### Author: ![jsoriano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsoriano/32/27920_2.png) [@jsoriano](https://discuss.elastic.co/u/jsoriano)
#### Post date: [July 6, 2022, 9:45am UTC](https://discuss.elastic.co/t/filebeat-error-logstash-async-go-280-client-is-not-connected/308874/2 "2022-07-06T09:45:17Z")

</div>

Hey @Ricard-CT,

Do you see other errors? If you don't, try to [enable debug logging](https://www.elastic.co/guide/en/beats/filebeat/8.2/configuration-logging.html) and look for some other message related to logstash.

Check also logstash logs in case you can find something there.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 3, 2022, 11:45am UTC](https://discuss.elastic.co/t/filebeat-error-logstash-async-go-280-client-is-not-connected/308874/3 "2022-08-03T11:45:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
