# Filebeat error on dashboard & elasticsearch server

**URL:** <https://discuss.elastic.co/t/filebeat-error-on-dashboard-elasticsearch-server/204820>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [October 23, 2019, 8:47am UTC](https://discuss.elastic.co/t/filebeat-error-on-dashboard-elasticsearch-server/204820 "2019-10-23T08:47:35Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![skyluke.1987](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Post date:** [October 23, 2019, 8:47am UTC](https://discuss.elastic.co/t/filebeat-error-on-dashboard-elasticsearch-server/204820/1 "2019-10-23T08:47:35Z")

</div>

After I downgraded from Filebeat 7.3.2 to 7.1.1. and my elasticsearch remains 7.3.2.

Then I encounter that filebeat cannot load the dashboards, and I followed by reloading the index and also the dashboards, but still having the same issue.

Please advise. Thanks

Secondly, may I know these rights is it correct? I keep getting this error: `error loading /usr/share/filebeat/kibana/7/dashboard/Filebeat-logstash-log.json: . Response: {"objects":[{"id":"0b1dace0-cbdb-11e7-9852-73e0a9df1bb6-ecs","type":"visualization","updated_at":"2019-10-23T09:41:58.795Z","version":"WzQyMTIyNiwyNl0=","attributes":{"description":"","kibanaSavedObjectMeta":{"searchSourceJSON":"{\"filter\":[],\"quer... (truncated)`

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/8/e/8eaa157457538ee9e459e1a52e5341ef1544f467.png)

---

<div class="post-metadata">

**Author:** ![faec](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/faec/32/46988_2.png) [@faec](https://discuss.elastic.co/u/faec)\
**Post date:** [October 23, 2019, 6:22pm UTC](https://discuss.elastic.co/t/filebeat-error-on-dashboard-elasticsearch-server/204820/2 "2019-10-23T18:22:20Z")

</div>

Dashboard configuration can change between versions, it's possible the newer version set something up that the older one doesn't know how to process. One thing to try is to [rerun the dashboard setup command](https://www.elastic.co/guide/en/beats/filebeat/current/load-kibana-dashboards.html) with your current filebeat version.

The permissions in your screenshot are probably ok but it looks like the file itself (`Filebeat-logstash-log.json`) is missing... that also makes it seem like a broken or incomplete dashboard setup.

---

<div class="post-metadata">

**Author:** ![skyluke.1987](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Post date:** [October 24, 2019, 2:02am UTC](https://discuss.elastic.co/t/filebeat-error-on-dashboard-elasticsearch-server/204820/3 "2019-10-24T02:02:43Z")

</div>

There is this file located in /usr/share/filebeat/kibana/7/dashboard/, but strangely the system has issue loading it.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/4/c40dfaffa764b9f88bf9438bb065379d92684836.png)

And my -filebeat-\* index in still receiving data daily.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/d/a/da562aabade41337e77c727142e58753fd1300ae.png)

---

<div class="post-metadata">

**Author:** ![skyluke.1987](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Post date:** [November 13, 2019, 2:37am UTC](https://discuss.elastic.co/t/filebeat-error-on-dashboard-elasticsearch-server/204820/4 "2019-11-13T02:37:43Z")

</div>

How can I adjust the amount of data collected on the nginx.access file?

Currently am collecting the following info in the log files only.  
`"GET /lta/image/ HTTP/1.1" 200 1866 "https://web.org/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.97 Safari/537.36"`

---

<div class="post-metadata">

**Author:** ![skyluke.1987](https://avatars.discourse-cdn.com/v4/letter/s/48db29/32.png) [@skyluke.1987](https://discuss.elastic.co/u/skyluke.1987)\
**Post date:** [November 14, 2019, 8:29am UTC](https://discuss.elastic.co/t/filebeat-error-on-dashboard-elasticsearch-server/204820/5 "2019-11-14T08:29:49Z")

</div>

Anyone here can help?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 12, 2019, 8:38am UTC](https://discuss.elastic.co/t/filebeat-error-on-dashboard-elasticsearch-server/204820/6 "2019-12-12T08:38:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
