# Filebeat error while importing kibana dashboard

**URL:** <https://discuss.elastic.co/t/filebeat-error-while-importing-kibana-dashboard/163954>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 11, 2019, 9:01pm UTC](https://discuss.elastic.co/t/filebeat-error-while-importing-kibana-dashboard/163954 "2019-01-11T21:01:00Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![samnayak](https://avatars.discourse-cdn.com/v4/letter/s/919ad9/32.png) [@samnayak](https://discuss.elastic.co/u/samnayak)\
**Post date:** [January 11, 2019, 9:01pm UTC](https://discuss.elastic.co/t/filebeat-error-while-importing-kibana-dashboard/163954/1 "2019-01-11T21:01:01Z")

</div>

I am getting below error while running filebeat. Can anyone help?

2019-01-11T14:54:40.684-0600 ERROR instance/beat.go:800 Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: Error creating Kibana client: fail to get the Kibana version: HTTP GET request to /api/status fails: \<nil\>. Response: {"statusCode":404,"error":"Not Found","message":"Not Found"}.

Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: Error creating Kibana client: fail to get the Kibana version: HTTP GET request to /api/status fails: \<nil\>. Response: {"statusCode":404,"error":"Not Found","message":"Not Found"}.

---

<div class="post-metadata">

**Author:** ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)\
**Post date:** [January 15, 2019, 4:48am UTC](https://discuss.elastic.co/t/filebeat-error-while-importing-kibana-dashboard/163954/2 "2019-01-15T04:48:47Z")

</div>

Hi,

Could you provide the following information:

1. What version of Filebeat are you running?

2. The exact, complete command that you ran when this error occurred.

3. The contents of your `filebeat.yml`, with any sensitive information redacted.

Thanks,

Shaunak

---

<div class="post-metadata">

**Author:** ![samnayak](https://avatars.discourse-cdn.com/v4/letter/s/919ad9/32.png) [@samnayak](https://discuss.elastic.co/u/samnayak)\
**Post date:** [January 15, 2019, 6:44pm UTC](https://discuss.elastic.co/t/filebeat-error-while-importing-kibana-dashboard/163954/3 "2019-01-15T18:44:42Z")

</div>

Hello,

1. I am using Filebeat 6.5 version.
2. ./filebeat
3. Contents of filebeat.yml

```auto
###################### Filebeat Configuration Example #########################

# This file is an example configuration file highlighting only the most common
# options. The filebeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/filebeat/index.html

# For more available modules and options, please see the filebeat.reference.yml sample
# configuration file.

#=========================== Filebeat inputs =============================

filebeat.inputs:

# Each - is an input. Most options can be set at the input level, so
# you can use different inputs for various configurations.
# Below are the input specific configurations.

- type: log

  # Change to true to enable this input configuration.
  enabled: true

  # Paths that should be crawled and fetched. Glob based paths.
  paths:
     - /Users/samnayak/elastcisearch_course/Data/logs/*
    #- /var/log/*.log
    #- c:\programdata\elasticsearch\logs\*

  # Exclude lines. A list of regular expressions to match. It drops the lines that are
  # matching any regular expression from the list.
  #exclude_lines: ['^DBG']

  # Include lines. A list of regular expressions to match. It exports the lines that are
  # matching any regular expression from the list.
  #include_lines: ['^ERR', '^WARN']

  # Exclude files. A list of regular expressions to match. Filebeat drops the files that
  # are matching any regular expression from the list. By default, no files are dropped.
  #exclude_files: ['.gz$']

  # Optional additional fields. These fields can be freely picked
  # to add additional information to the crawled log files for filtering
  #fields:
  # level: debug
  # review: 1

  ### Multiline options

  # Multiline can be used for log messages spanning multiple lines. This is common
  # for Java Stack Traces or C-Line Continuation

  # The regexp Pattern that has to be matched. The example pattern matches all lines starting with [
  #multiline.pattern: ^\[

  # Defines if the pattern set under pattern should be negated or not. Default is false.
  #multiline.negate: false

  # Match can be set to "after" or "before". It is used to define if lines should be append to a pattern
  # that was (not) matched before or after or as long as a pattern is not matched based on negate.
  # Note: After is the equivalent to previous and before is the equivalent to to next in Logstash
  #multiline.match: after

#============================= Filebeat modules ===============================

filebeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 3
  #index.codec: best_compression
  #_source.enabled: false

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
# env: staging

#============================== Dashboards =====================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here, or by using the `-setup` CLI flag or the `setup` command.
#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana.host: "192.0.2.255:5601"
setup.kibana.protocol: "http"
setup.kibana.path: /kibana

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  #host: "localhost:5601"

  # Kibana Space ID
  # ID of the Kibana Space into which the dashboards should be loaded. By default,
  # the Default Space will be used.
  #space.id:

#============================= Elastic Cloud ==================================

# These settings simplify using filebeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

```

Thank You!

---

<div class="post-metadata">

**Author:** ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)\
**Post date:** [January 17, 2019, 2:29am UTC](https://discuss.elastic.co/t/filebeat-error-while-importing-kibana-dashboard/163954/4 "2019-01-17T02:29:43Z")

</div>

Thanks, could you post the output of running the following commands from the same host as where Filebeat is supposed to run:

1. `./filebeat -e`

2. `curl -v http://192.0.2.255:5601/kibana`

3. `curl -v http://192.0.2.255:5601/kibana/api/status`

4. `curl -v http://192.0.2.255:5601/api/status`

Thanks,

Shaunak

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 14, 2019, 2:29am UTC](https://discuss.elastic.co/t/filebeat-error-while-importing-kibana-dashboard/163954/5 "2019-02-14T02:29:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
