# Filebeat Error

**URL:** <https://discuss.elastic.co/t/filebeat-error/320316>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [December 2, 2022, 3:04am UTC](https://discuss.elastic.co/t/filebeat-error/320316 "2022-12-02T03:04:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![lucas.Jung](https://avatars.discourse-cdn.com/v4/letter/l/ac8455/32.png) [@lucas.Jung](https://discuss.elastic.co/u/lucas.Jung)\
**Post date:** [December 2, 2022, 3:04am UTC](https://discuss.elastic.co/t/filebeat-error/320316/1 "2022-12-02T03:04:25Z")

</div>

I set filebeat to use the ingest node of okta, but an error occurs and filebit does not run.

ERROR [esclientleg] transport/logging.go:37 Error dialing x509: certificate signed by unknown authority {"network": "tcp", "address": "10.10.10.10:9200"}  
2022-12-02T03:11:39.817Z ERROR [esclientleg] eslegclient/connection.go:232 error connecting to Elasticsearch at [https://10.10.10.10:9200](https://10.10.10.10:9200): Get "[https://10.10.10.10:9200](https://10.10.10.10:9200)": x509: certificate signed by unknown authority  
2022-12-02T03:11:39.817Z ERROR instance/beat.go:1014 Exiting: couldn't connect to any of the configured Elasticsearch hosts. Errors: [error connecting to Elasticsearch at [https://10.10.10.10:9200](https://10.10.10.10:9200): Get "[https://10.10.10.10:9200](https://10.10.10.10:9200)": x509: certificate signed by unknown authority]  
Exiting: couldn't connect to any of the configured Elasticsearch hosts. Errors: [error connecting to Elasticsearch at [https://10.10.10.10:9200](https://10.10.10.10:9200): Get "[https://10.10.10.10:9200](https://10.10.10.10:9200)": x509: certificate signed by unknown authority]

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 2, 2022, 3:29am UTC](https://discuss.elastic.co/t/filebeat-error/320316/2 "2022-12-02T03:29:07Z")

</div>

Welcome to our community! 😃

> [@lucas.Jung](#):
>
> x509: certificate signed by unknown authority

That would be why, there's a tonne of web search hits on approaches to fix this. How did you create your certificates?

---

<div class="post-metadata">

**Author:** ![lucas.Jung](https://avatars.discourse-cdn.com/v4/letter/l/ac8455/32.png) [@lucas.Jung](https://discuss.elastic.co/u/lucas.Jung)\
**Post date:** [December 2, 2022, 8:30am UTC](https://discuss.elastic.co/t/filebeat-error/320316/3 "2022-12-02T08:30:05Z")

</div>

I struggled a lot to solve this problem.  
Resolved with "ssl.verification\_mode: "none".

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 30, 2022, 10:30am UTC](https://discuss.elastic.co/t/filebeat-error/320316/4 "2022-12-30T10:30:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
