# Filebeat errors on setup - Apache ingest pipelines failing to load

**URL:** <https://discuss.elastic.co/t/filebeat-errors-on-setup-apache-ingest-pipelines-failing-to-load/265134>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 22, 2021, 10:45pm UTC](https://discuss.elastic.co/t/filebeat-errors-on-setup-apache-ingest-pipelines-failing-to-load/265134 "2021-02-22T22:45:21Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![QueenAmidala](https://avatars.discourse-cdn.com/v4/letter/q/ce7236/32.png) [@QueenAmidala](https://discuss.elastic.co/u/QueenAmidala)\
**Post date:** [February 23, 2021, 4:02am UTC](https://discuss.elastic.co/t/filebeat-errors-on-setup-apache-ingest-pipelines-failing-to-load/265134/3 "2021-02-23T04:02:06Z")

</div>

This seems to also be a problem for these people [Error trying to setup filebeat](https://discuss.elastic.co/t/error-trying-to-setup-filebeat/257011) because the error response structure for a visualization is actually more like [kibana/types.ts at v7.11.1 · elastic/kibana · GitHub](https://github.com/elastic/kibana/blob/v7.11.1/x-pack/plugins/ml/common/util/errors/types.ts#L26) when you run filebeats setup for the first time and the error message doesn't match with what is looked for in the code.

Is there no desire to fix this because it is legacy code? Can the machine learning option for filebeat setup at least be disabled by default?

I'm using version 7.11.1 of Elastic. So, like Elasticsearch 7.11.1, Kibana 7.11.1, and Filebeat 7.11.1. I'm using the container images.

---

_[View the full topic](https://discuss.elastic.co/t/filebeat-errors-on-setup-apache-ingest-pipelines-failing-to-load/265134)._
