# Filebeat Failed to connect to backoff(async(tcp:logstash:5044

**URL:** <https://discuss.elastic.co/t/filebeat-failed-to-connect-to-backoff-async-tcp5044/321390>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [December 16, 2022, 9:27am UTC](https://discuss.elastic.co/t/filebeat-failed-to-connect-to-backoff-async-tcp5044/321390 "2022-12-16T09:27:25Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Coder\_HK](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/coder_hk/32/57814_2.png) [@Coder\_HK](https://discuss.elastic.co/u/Coder_HK)\
**Post date:** [December 16, 2022, 9:27am UTC](https://discuss.elastic.co/t/filebeat-failed-to-connect-to-backoff-async-tcp5044/321390/1 "2022-12-16T09:27:25Z")

</div>

I have set two VMs, one Ubuntu where I've installed ELK and another CentOS where I've installed Filebeat. I want to forward CentOS logs to ELK via filebeat. I have configured all my files correctly (I think) but when I run filebeat to forward logs to Logstash it gives the above error. If I change the output from logstash to Elasticsearch, the filebeat stops working and it gives the error **Failed to start Filebeat sends log files to L..........**

**This is my Logstash COnfiguration in /etc/logstash/logstash.yml file**

```auto
path.data: /var/lib/logstash
path.logs: /var/log/logstash

```

**/logstash/conf.d/filebeat.conf file...**

```auto
input {
  beats {
    port => 5044
          }

}

filter {

}

output {

  elasticsearch {

    hosts => ["http://localhost:9200"]
    index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
    user => "elastic"
    password => "my_elastic_password"

```

**selasticsearch.yml file...**

```auto
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
xpack.security.enabled: true
xpack.security.enrollment.enabled: true
xpack.security.http.ssl:
  enabled: true
  keystore.path: certs/http.p12
xpack.security.transport.ssl:
  enabled: true
  verification_mode: certificate
  keystore.path: certs/transport.p12
  truststore.path: certs/transport.p12
cluster.initial_master_nodes: ["hilmand-virtual-machine"]
http.host: 0.0.0.0

```

**filebeat.yml file...**

```auto
filebeat.inputs:
- type: log
enable: true

paths:
- /var/log/*.log

filebeat.config.modules:
 path: ${path.config}/modules.d/*.yml
reload.enabled: dalse
setup.template.settings:
index.number_of_shards: 1

setup.kibana:
host: "192.168.254.66:5601"

**output.logstash:
**

hosts:
- 192.168.254.66:5044

```

**all the ssl certificate related stuff is commented out**

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 13, 2023, 11:28am UTC](https://discuss.elastic.co/t/filebeat-failed-to-connect-to-backoff-async-tcp5044/321390/2 "2023-01-13T11:28:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
