# Filebeat failed to connect to backoff error

**URL:** https://discuss.elastic.co/t/filebeat-failed-to-connect-to-backoff-error/360892
**Category:** Elastic Agent
**Tags:** filebeat
**Created:** [June 5, 2024, 10:42pm UTC](https://discuss.elastic.co/t/filebeat-failed-to-connect-to-backoff-error/360892 "2024-06-05T22:42:36Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![mealbert23](https://avatars.discourse-cdn.com/v4/letter/m/53a042/32.png) [@mealbert23](https://discuss.elastic.co/u/mealbert23)
#### Post date: [June 5, 2024, 10:42pm UTC](https://discuss.elastic.co/t/filebeat-failed-to-connect-to-backoff-error/360892/1 "2024-06-05T22:42:36Z")

</div>

Hi,

I am very new to the world of elastic but have learned a lot via trial and error over the last few weeks. I have setup elastic/kibana on a AWS EKS system. Elasticsearch and kibana reside in a private subnet and kibana is accessible via an ALB. I am now trying to setup filebeat to work with s3/sqs setup. When I upload a json to s3 it looks like filebeat is correctly seeing the message in sqs but I am getting the following error now. "message":"Failed to connect to backoff(elasticsearch([http://ipaddress|host:9200](http://ipaddress%7Chost:9200)): Get "" EOF. The urls I have tried:

- ip address of elastic-es-http
- full output elasticsearch url found in Fleet -\> settings
- publicly accessible kibana url:9200

I have looked at some of the other topics around this issue but a lot of them are prior to 8.1. I think this is the last piece of the puzzle I am missing to get this whole setup working so any help would be greatly appreciated.

Thanks,  
Mark
