# Filebeat :- Failed to publish events caused by: client is not connected

**URL:** <https://discuss.elastic.co/t/filebeat-failed-to-publish-events-caused-by-client-is-not-connected/217603>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 3, 2020, 10:16am UTC](https://discuss.elastic.co/t/filebeat-failed-to-publish-events-caused-by-client-is-not-connected/217603 "2020-02-03T10:16:05Z")\
**Posts on this page:** 1\
**Showing post:** 8

<div class="post-metadata">

**Author:** ![dillip1](https://avatars.discourse-cdn.com/v4/letter/d/258eb7/32.png) [@dillip1](https://discuss.elastic.co/u/dillip1)\
**Post date:** [February 10, 2020, 4:35pm UTC](https://discuss.elastic.co/t/filebeat-failed-to-publish-events-caused-by-client-is-not-connected/217603/8 "2020-02-10T16:35:02Z")

</div>

Okay. Issue is solved. I just added the **client\_ inactivity\_timeout** parameter in logstash conf file.

> [@\[SOLVED\] TCP "RST"/reset causing Filebeat/Logstash connection reset](https://discuss.elastic.co/t/solved-tcp-rst-reset-causing-filebeat-logstash-connection-reset/82343/3):
>
> I'm embarrassed it took me so long to solve this. Turns out all I needed to do was specify a client\_inactivity\_timeout of more than the default of 60 seconds. In my particular situation the client (on a test server) was relatively inactive, causing Logstash to kill the connection after 60 seconds. Increasing this beyond the inactivity time resolved the issue. input { beats { client\_inactivity\_timeout =\> 1200 port =\> 5044 } } Thanks, Greg

---

_[View the full topic](https://discuss.elastic.co/t/filebeat-failed-to-publish-events-caused-by-client-is-not-connected/217603)._
