# Filebeat failed to start after adding add\_host\_metadata

**URL:** <https://discuss.elastic.co/t/filebeat-failed-to-start-after-adding-add-host-metadata/177467>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 18, 2019, 1:08pm UTC](https://discuss.elastic.co/t/filebeat-failed-to-start-after-adding-add-host-metadata/177467 "2019-04-18T13:08:41Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![r.ganeshbabu](https://avatars.discourse-cdn.com/v4/letter/r/4da419/32.png) [@r.ganeshbabu](https://discuss.elastic.co/u/r.ganeshbabu)\
**Post date:** [April 18, 2019, 1:08pm UTC](https://discuss.elastic.co/t/filebeat-failed-to-start-after-adding-add-host-metadata/177467/1 "2019-04-18T13:08:41Z")

</div>

Hi All,

We are trying to send logs using filebeat and we added the **add\_host\_metadata** processor to our beats yml files.

But it not working on Windows Server 2016 64-bit servers and below is the system details,

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/e/fec9fcd7b4790a6a1569e65c23da587e04ba9f5f.png)

Any idea's on how to solve this?

The added part:

```
processors:
- add_host_metadata: ~

```

When adding this to the yml file of filebeat the service crashes and the following error is logged:

> PS C:\ProgramData\filebeat-6.3.2-windows-x86\_64\> .\filebeat.exe -c .\filebeat.yml -e -d "\*"  
> 2019-04-18T12:44:57.921Z INFO instance/beat.go:492 Home path: [C:\ProgramData\filebeat-6.3.2-windows-x86\_64] Config path: [C:\ProgramData\filebeat-6.3.2-windows-x86\_64] Data path:  
> [C:\ProgramData\filebeat-6.3.2-windows-x86\_64\data] Logs path: [C:\ProgramData\filebeat-6.3.2-windows-x86\_64\logs]  
> 2019-04-18T12:44:57.991Z DEBUG [beat] instance/beat.go:519 Beat metadata path: C:\ProgramData\filebeat-6.3.2-windows-x86\_64\data\meta.json  
> 2019-04-18T12:44:57.992Z INFO instance/beat.go:499 Beat UUID: 1f9eae26-52c5-4340-9861-401b83536402  
> 2019-04-18T12:44:57.992Z INFO [beat] instance/beat.go:716 Beat info {"system\_info": {"beat": {"path": {"config": "C:\ProgramData\filebeat-6.3.2-windows-x86\_64", "data": "  
> C:\ProgramData\filebeat-6.3.2-windows-x86\_64\data", "home": "C:\ProgramData\filebeat-6.3.2-windows-x86\_64", "logs": "C:\ProgramData\filebeat-6.3.2-windows-x86\_64\logs"}, "type": "filebeat", "uuid": "1f9eae26-52c5-4340-9861-401b83536402"}}}  
> 2019-04-18T12:44:57.992Z INFO [beat] instance/beat.go:725 Build info {"system\_info": {"build": {"commit": "45a9a9e1561b6c540e94211ebe03d18abcacae55", "libbeat": "6.3.2", "time": "2018-07-20T04:17:39.000Z", "version": "6.3.2"}}}  
> 2019-04-18T12:44:57.993Z INFO [beat] instance/beat.go:728 Go runtime info {"system\_info": {"go":{"os":"windows","arch":"amd64","max\_procs":4,"version":"go1.9.4"}}}  
> 2019-04-18T12:44:58.000Z INFO instance/beat.go:225 Setup Beat: filebeat; Version: 6.3.2  
> 2019-04-18T12:44:58.000Z DEBUG [beat] instance/beat.go:242 Initializing output plugins  
> 2019-04-18T12:44:58.011Z INFO instance/beat.go:275 filebeat stopped.  
> 2019-04-18T12:44:58.011Z ERROR instance/beat.go:691 Exiting: error initializing publisher: error initializing processors: 1 error: GetFileVersionInfoSize failed: The system cannot find the file specified.  
> Exiting: error initializing publisher: error initializing processors: 1 error: GetFileVersionInfoSize failed: The system cannot find the file specified.

**Note:** - I have tried other versions of filebeat like 6.4.0, 6.5.4 and I am getting the same error

Please help us to resolve this issue.

Thanks,  
Ganeshbabu R

---

<div class="post-metadata">

**Author:** ![shaunak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shaunak/32/6643_2.png) [@shaunak](https://discuss.elastic.co/u/shaunak)\
**Post date:** [April 18, 2019, 3:43pm UTC](https://discuss.elastic.co/t/filebeat-failed-to-start-after-adding-add-host-metadata/177467/2 "2019-04-18T15:43:14Z")

</div>

It looks like you filed a bug for this on GitHub: [https://github.com/elastic/beats/issues/11864](https://github.com/elastic/beats/issues/11864). That's perfect, thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 16, 2019, 3:43pm UTC](https://discuss.elastic.co/t/filebeat-failed-to-start-after-adding-add-host-metadata/177467/3 "2019-05-16T15:43:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
