# Filebeat fails to send monitoring stats to Elasticsearch

**URL:** https://discuss.elastic.co/t/filebeat-fails-to-send-monitoring-stats-to-elasticsearch/124635
**Category:** Beats
**Tags:** filebeat
**Created:** [March 19, 2018, 8:00pm UTC](https://discuss.elastic.co/t/filebeat-fails-to-send-monitoring-stats-to-elasticsearch/124635 "2018-03-19T20:00:39Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![mn\_dev](https://avatars.discourse-cdn.com/v4/letter/m/7cd45c/32.png) [@mn\_dev](https://discuss.elastic.co/u/mn_dev)
#### Post date: [March 19, 2018, 8:00pm UTC](https://discuss.elastic.co/t/filebeat-fails-to-send-monitoring-stats-to-elasticsearch/124635/1 "2018-03-19T20:00:39Z")

</div>

I cannot seem to setup the xpack monitoring of Filebeats successfully.

Filebeats keeps logging error messages similar to:

2018-03-19T12:29:20.396-0700 ERROR pipeline/output.go:92 Failed to publish events: 500 Internal Server Error: {"took":9,"errors":true,"error":{"type":"export\_exception","reason":"failed to add documents to export bulks","exceptions":[{"type":"export\_exception","reason":"failed to add documents to export bulk [default\_local]","exceptions":[{"type":"export\_exception","reason":"failed to add document [org.elasticsearch.xpack.monitoring.action.MonitoringBulkDoc@35dd5055]","caused\_by":{"type":"illegal\_argument\_exception","reason":"No resolver found for monitoring document"}}]}]}}

whenever it attempts to send the monitoring stats to Elasticsearch.

Any help resolving this error message?

My filebeat.yml x-pack settings:

```
#============================== Xpack Monitoring ===============================
# filebeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
xpack.monitoring.enabled: true

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well. Any setting that is not set is
# automatically inherited from the Elasticsearch output configuration, so if you
# have the Elasticsearch output configured, you can simply uncomment the
# following line.
xpack.monitoring.elasticsearch:
    hosts: ["kibana:9200"]
```

---

<div class="post-metadata">

### Author: ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)
#### Post date: [March 21, 2018, 7:06am UTC](https://discuss.elastic.co/t/filebeat-fails-to-send-monitoring-stats-to-elasticsearch/124635/2 "2018-03-21T07:06:04Z")

</div>

Which version of Filebeat are you using? Which version of Elasticsearch and Kibana?

---

<div class="post-metadata">

### Author: ![mn\_dev](https://avatars.discourse-cdn.com/v4/letter/m/7cd45c/32.png) [@mn\_dev](https://discuss.elastic.co/u/mn_dev)
#### Post date: [March 21, 2018, 1:31pm UTC](https://discuss.elastic.co/t/filebeat-fails-to-send-monitoring-stats-to-elasticsearch/124635/3 "2018-03-21T13:31:02Z")

</div>

Filebeat: 6.2.2

Apparently, 5.6.4 for Elasticsearch and Kibana rather than the 6+ that I thought. I'm guessing the error will go away upon upgrading then?

---

<div class="post-metadata">

### Author: ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)
#### Post date: [March 21, 2018, 1:55pm UTC](https://discuss.elastic.co/t/filebeat-fails-to-send-monitoring-stats-to-elasticsearch/124635/4 "2018-03-21T13:55:38Z")

</div>

Yes, you need at least 6.2

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 18, 2018, 1:55pm UTC](https://discuss.elastic.co/t/filebeat-fails-to-send-monitoring-stats-to-elasticsearch/124635/5 "2018-04-18T13:55:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
