# Filebeat fails to start when output is set to file

**URL:** <https://discuss.elastic.co/t/filebeat-fails-to-start-when-output-is-set-to-file/220328>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 21, 2020, 10:06am UTC](https://discuss.elastic.co/t/filebeat-fails-to-start-when-output-is-set-to-file/220328 "2020-02-21T10:06:19Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ldv](https://avatars.discourse-cdn.com/v4/letter/l/0ea827/32.png) [@ldv](https://discuss.elastic.co/u/ldv)\
**Post date:** [February 21, 2020, 10:06am UTC](https://discuss.elastic.co/t/filebeat-fails-to-start-when-output-is-set-to-file/220328/1 "2020-02-21T10:06:19Z")

</div>

I am quite new to filebeat and the ELK stack. After succesfully building a Filebeat, Elastic and Kibana stack indexing apache access logfiles, I wanted to use Filebeat to send output to a file for testing purposes. However, I keep running into an error. Filebeat starts and then immediately exits again because it is looking for elastic.

The relevant part of the logfile is below.

```
2020-02-20T16:19:40.794+0100	WARN	beater/filebeat.go:152	Filebeat is unable to load the Ingest Node pipelines for the configured modules because the Elasticsearch output is not configured/enabled. If you have already loaded the Ingest Node pipelines or are using Logstash pipelines, you can ignore this warning.
2020-02-20T16:19:40.794+0100	ERROR	instance/beat.go:916	Exiting: Index management requested but the Elasticsearch output is not configured/enabled

```

Below is the filebeat.yml that is used.

```auto
#=========================== Filebeat inputs =============================

filebeat.inputs:
- type: log
  enabled: true
  paths:
    - C:\Some\folder\*

#============================= Filebeat modules ===============================

filebeat.config.modules:
  path: C:\another\folder\*.yml
  reload.enabled: true

#------------------------------- File output -----------------------------------
output.file:
  enabled: true
  path: 'C:\Yet\another\folder\'
  filename: filebeat

```

I have also configured an apache.yml

```auto
- module: apache
  # Access logs
  access:
    enabled: true

    # Set custom paths for the log files. If left empty,
    # Filebeat will choose the paths depending on your OS.
    var.paths: ['C:\Some\Folder\2\Access*']

```

Filebeat keeps asking for the elastic output to be configured, but only one output can be configured at a time.  
Is there a some option I need to set?  
I am using Elastic stack 7.5 on a windows 10 laptop

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 20, 2020, 10:06am UTC](https://discuss.elastic.co/t/filebeat-fails-to-start-when-output-is-set-to-file/220328/2 "2020-03-20T10:06:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
