# Filebeat harvesters don't restart after stopping due to ignore\_older

**URL:** https://discuss.elastic.co/t/filebeat-harvesters-dont-restart-after-stopping-due-to-ignore-older/38046
**Category:** Beats
**Tags:** filebeat
**Created:** [December 28, 2015, 1:28pm UTC](https://discuss.elastic.co/t/filebeat-harvesters-dont-restart-after-stopping-due-to-ignore-older/38046 "2015-12-28T13:28:32Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![pghalliday](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pghalliday/32/6863_2.png) [@pghalliday](https://discuss.elastic.co/u/pghalliday)
#### Post date: [December 28, 2015, 2:02pm UTC](https://discuss.elastic.co/t/filebeat-harvesters-dont-restart-after-stopping-due-to-ignore-older/38046/2 "2015-12-28T14:02:45Z")

</div>

Ok just spotted this one:

> [@Ignore\_older - Infrequently updated log file](https://discuss.elastic.co/t/ignore-older-infrequently-updated-log-file/34532):
>
> I just migrated to filebeats yesterday, am just starting to look into how it's performing. Need some clarification on the ignore\_older parameter. Does this mean if a file hasn't been updated in the defined time, it is no longer checked at all? I have some error logs that may not get updated entries for hours or days. I am using the default of 10 mins. Thanks

And it seems that my expectation is correct and the harvester should restart.

Is this a bug or a misconfiguration on my part - I wondered if it was a corner case due to the file being empty when it is ignored :s

My configuration is really simple

```auto
---
filebeat:
  prospectors:
  - paths:
    - "/var/log/nginx/*access.log"
    document_type: nginx_access

```

I am using a config\_dir to define prospectors in separate files.

This is my main config (comments removed for brevity) - it's mostly defaults

```auto
filebeat:
  prospectors:
    -
      type: stdin
      paths:
        - "-"

  registry_file: /var/lib/filebeat/registry
  config_dir: /etc/filebeat/conf.d

output:
  logstash:
    hosts: ["logstash.myserver.com:5044"]

shipper:

logging:
  files:
    rotateeverybytes: 10485760 # = 10MB

```

The weirdest thing is the `stdin` prospector - this is because I use Chef to add prospector files and initially there are no prospectors - Filebeat doesn't like it when you try to start it with no prospectors (I will raise this as a separate issue)

Oh, and the other prospectors are defined thus:

```auto
---
filebeat:
  prospectors:
  - paths:
    - "/var/log/nginx/*error.log"
    document_type: nginx_error

```

```auto
---
filebeat:
  prospectors:
  - paths:
    - "/var/log/syslog"
    document_type: syslog

```

---

_[View the full topic](https://discuss.elastic.co/t/filebeat-harvesters-dont-restart-after-stopping-due-to-ignore-older/38046)._
