# Filebeat httpjason input

**URL:** <https://discuss.elastic.co/t/filebeat-httpjason-input/255813>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [November 18, 2020, 9:32am UTC](https://discuss.elastic.co/t/filebeat-httpjason-input/255813 "2020-11-18T09:32:00Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![pankaj](https://avatars.discourse-cdn.com/v4/letter/p/a9adbd/32.png) [@pankaj](https://discuss.elastic.co/u/pankaj)\
**Post date:** [November 18, 2020, 9:32am UTC](https://discuss.elastic.co/t/filebeat-httpjason-input/255813/1 "2020-11-18T09:32:00Z")

</div>

I tried configure the test httpjson input but that failing filebeat service to start.

filebeat.inputs:

# Fetch your public IP every minute.

- type: httpjson  
url: [https://api.ipify.org/?format=json](https://api.ipify.org/?format=json)  
interval: 1m  
processors:
  - decode\_json\_fields  
fields: [message]  
target: json

---

<div class="post-metadata">

**Author:** ![MarianaD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marianad/32/42687_2.png) [@MarianaD](https://discuss.elastic.co/u/MarianaD)\
**Post date:** [November 18, 2020, 3:24pm UTC](https://discuss.elastic.co/t/filebeat-httpjason-input/255813/2 "2020-11-18T15:24:15Z")

</div>

hi @pankaj, what do you mean by filebeat failing to start, can you provide us with the filebeat log? That might provide some information on the issue you might be having (you can also set the logging level to debug for more information).

---

<div class="post-metadata">

**Author:** ![pankaj](https://avatars.discourse-cdn.com/v4/letter/p/a9adbd/32.png) [@pankaj](https://discuss.elastic.co/u/pankaj)\
**Post date:** [November 18, 2020, 4:47pm UTC](https://discuss.elastic.co/t/filebeat-httpjason-input/255813/3 "2020-11-18T16:47:11Z")

</div>

Mariana

Please find below the service status details

root@elk-filebeat:/home/elkadmin# service filebeat status  
● filebeat.service - Filebeat sends log files to Logstash or directly to Elasticsearch.  
Loaded: loaded (/lib/systemd/system/filebeat.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Wed 2020-11-18 22:12:42 UTC; 5h 26min left  
Docs: [https://www.elastic.co/products/beats/filebeat](https://www.elastic.co/products/beats/filebeat)  
Process: 1766 ExecStart=/usr/share/filebeat/bin/filebeat --environment systemd $BEAT\_LOG\_OPTS $BEAT\_CONFIG\_OPTS $BEAT\_PATH\_OPTS (code=exited, status=1/FAILURE)  
Main PID: 1766 (code=exited, status=1/FAILURE)

Nov 18 22:12:42 elk-filebeat systemd[1]: filebeat.service: Service hold-off time over, scheduling restart.  
Nov 18 22:12:42 elk-filebeat systemd[1]: filebeat.service: Scheduled restart job, restart counter is at 9.  
Nov 18 22:12:42 elk-filebeat systemd[1]: Stopped Filebeat sends log files to Logstash or directly to Elasticsearch..  
Nov 18 22:12:42 elk-filebeat systemd[1]: filebeat.service: Start request repeated too quickly.  
Nov 18 22:12:42 elk-filebeat systemd[1]: filebeat.service: Failed with result 'exit-code'.  
Nov 18 22:12:42 elk-filebeat systemd[1]: Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch..

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 16, 2020, 7:07pm UTC](https://discuss.elastic.co/t/filebeat-httpjason-input/255813/5 "2020-12-16T19:07:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
