# Filebeat i/o timeout error

**URL:** <https://discuss.elastic.co/t/filebeat-i-o-timeout-error/266581>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [March 8, 2021, 3:36pm UTC](https://discuss.elastic.co/t/filebeat-i-o-timeout-error/266581 "2021-03-08T15:36:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![iammanmale](https://avatars.discourse-cdn.com/v4/letter/i/5e9695/32.png) [@iammanmale](https://discuss.elastic.co/u/iammanmale)\
**Post date:** [March 8, 2021, 3:36pm UTC](https://discuss.elastic.co/t/filebeat-i-o-timeout-error/266581/1 "2021-03-08T15:36:46Z")

</div>

We are using filebeat on aws windows machines to push their log to local logstash and then local ES.  
Recently, some error occurs when I enter the command to test the output status on those AWS machines.  
The command is filebeat.exe test output and the output is like  
$ ./filebeat.exe test output  
2021-03-08 23:09:58.1009325 +0800 CST m=+0.152997401 write error: failed to rotate backups: failed to rotate backups:  
rename C:\Program Files\Filebeat\logs\filebeat C:\Program Files\Filebeat\logs\filebeat-2021-03-08-23-1: The process  
cannot access the file because it is being used by another process.  
2021-03-08 23:09:58.1019319 +0800 CST m=+0.153996801 write error: failed to rotate backups: failed to rotate backups:  
rename C:\Program Files\Filebeat\logs\filebeat C:\Program Files\Filebeat\logs\filebeat-2021-03-08-23-1: The process  
cannot access the file because it is being used by another process.  
logstash: elasticsearchnode:xxxx...  
connection...  
parse host... OK  
dns lookup... OK  
addresses: xxx.xxx.xxx.xxx  
dial up... OK  
TLS...  
security: server's certificate chain verification is enabled  
handshake... ERROR read tcp xxx.xxx.xxxx.xxx:xxxxx-\>xxx.xxx.xxx.xxx:xxxx: i/o timeout

I am not sure why it show the log file is used by other process because there is only one filebeat instance on the machine. And although the i/o is timeout, the log is being pushed actually. If I run the command on local machine with filebeat, there is no error.  
Is there any one who could shed some light on it?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 5, 2021, 5:37pm UTC](https://discuss.elastic.co/t/filebeat-i-o-timeout-error/266581/2 "2021-04-05T17:37:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
