# Filebeat ingesta de AWS CloudTrail

**URL:** <https://discuss.elastic.co/t/filebeat-ingesta-de-aws-cloudtrail/294184>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 12, 2022, 4:21pm UTC](https://discuss.elastic.co/t/filebeat-ingesta-de-aws-cloudtrail/294184 "2022-01-12T16:21:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Elisa\_LB](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/elisa_lb/32/109214_2.png) [@Elisa\_LB](https://discuss.elastic.co/u/Elisa_LB)\
**Post date:** [January 12, 2022, 4:21pm UTC](https://discuss.elastic.co/t/filebeat-ingesta-de-aws-cloudtrail/294184/1 "2022-01-12T16:21:00Z")

</div>

Buenas tardes,

Estoy teniendo inconvenientes con la ingesta de AWS CloudTrail mediante filebeat, tengo el agente conectado a la consola de Elastic Cloud y la configuración del modulo de aws en filebeat desde la consola Cloud me aparece el siguiente error y desde file beat me aparece lo siguiente.

Error de Filebeat:

/usr/local/go/src/runtime/asm\_amd64.s:1581

Exiting: Failed to start crawler: creating module reloader failed: 2 errors: invalid config: config file ("/etc/filebeat-7.16.2-darwin-x86\_64/modules.d/aws.yml") must be owned by the user identifier (uid=0) or root; invalid config: config file ("/etc/filebeat-7.16.2-darwin-x86\_64/modules.d/okta.yml") must be owned by the user identifier (uid=0) or root  
loading configs

Error en Kibana:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/4/741fc3895ac7303508907e2a23001a07f5918095.png)

Soy nueva en esta tarea de ingestar en Elasticsearch y aun no encontré con el kb o solución para poder ingestar AWS CloudTrail.

Si alguien me puede ayudar será estaría muy agradecida.

Saludos!

---

<div class="post-metadata">

**Author:** ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)\
**Post date:** [January 14, 2022, 9:46am UTC](https://discuss.elastic.co/t/filebeat-ingesta-de-aws-cloudtrail/294184/2 "2022-01-14T09:46:31Z")

</div>

Hola @Elisa_LB 🙂

El error te ha dado alguna pista ya: _`/etc/filebeat-7.16.2-darwin-x86_64/modules.d/aws.yml` must be owned by the user identifier (uid=0) or root_

Tendrías que cambiar el propietario del fichero `aws.yml` y `okta.yml` a `root`

```auto
chown root /etc/filebeat-7.16.2-darwin-x86_64/modules.d/okta.yml
chown root /etc/filebeat-7.16.2-darwin-x86_64/modules.d/aws.yml

```

Esto no es generalmente necesario y probablemente lo ha causado haber hecho modificaciones usando el usuario root.

¡Un saludo!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 11, 2022, 11:46am UTC](https://discuss.elastic.co/t/filebeat-ingesta-de-aws-cloudtrail/294184/3 "2022-02-11T11:46:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
