# Filebeat initializing error for s3

**URL:** <https://discuss.elastic.co/t/filebeat-initializing-error-for-s3/269137>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 3, 2021, 1:08am UTC](https://discuss.elastic.co/t/filebeat-initializing-error-for-s3/269137 "2021-04-03T01:08:58Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![paano](https://avatars.discourse-cdn.com/v4/letter/p/cab0a1/32.png) [@paano](https://discuss.elastic.co/u/paano)\
**Post date:** [April 3, 2021, 1:08am UTC](https://discuss.elastic.co/t/filebeat-initializing-error-for-s3/269137/1 "2021-04-03T01:08:58Z")

</div>

I am trying to follow as explained in the elastic [blog](https://www.elastic.co/blog/getting-aws-logs-from-s3-using-filebeat-and-the-elastic-stack)

And getting error:

```
2021-04-03T01:04:23.845Z	ERROR	instance/beat.go:971	Exiting: Failed to start crawler: starting input failed: Error while initializing input: Error creating input. No such input type exist: 's3'
Exiting: Failed to start crawler: starting input failed: Error while initializing input: Error creating input. No such input type exist: 's3'
[centos@ip-10.10.6.8 filebeat-7.12.0-linux-x86_64]$

```

What would be the reason for this. Any pointers.

---

<div class="post-metadata">

**Author:** ![legoguy1000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/legoguy1000/32/54301_2.png) [@legoguy1000](https://discuss.elastic.co/u/legoguy1000)\
**Post date:** [April 3, 2021, 1:37pm UTC](https://discuss.elastic.co/t/filebeat-initializing-error-for-s3/269137/2 "2021-04-03T13:37:40Z")

</div>

The input name was changed to `aws-s3` around the release of 7.10

---

<div class="post-metadata">

**Author:** ![paano](https://avatars.discourse-cdn.com/v4/letter/p/cab0a1/32.png) [@paano](https://discuss.elastic.co/u/paano)\
**Post date:** [April 3, 2021, 1:42pm UTC](https://discuss.elastic.co/t/filebeat-initializing-error-for-s3/269137/3 "2021-04-03T13:42:56Z")

</div>

after reading i see it it should be `aws-s3` Giving it a try.

---

<div class="post-metadata">

**Author:** ![paano](https://avatars.discourse-cdn.com/v4/letter/p/cab0a1/32.png) [@paano](https://discuss.elastic.co/u/paano)\
**Post date:** [April 3, 2021, 1:53pm UTC](https://discuss.elastic.co/t/filebeat-initializing-error-for-s3/269137/4 "2021-04-03T13:53:31Z")

</div>

thanks @legoguy1000

I see access denied, will work on that.  
`2021-04-03T13:45:04.022Z	ERROR	[input.aws-s3]	awss3/collector.go:101	SQS ReceiveMessageRequest failed: AccessDenied: Access to the resource https://sqs.us-east-1.amazonaws.com/ is denied.`

`status code: 403, request id: 4d205118-6b7e-545d-96f0-09fa18e103cd	{"queue_url": "https://sqs.us-east-1.amazonaws.com/12345678901/log-queue-dev", "region": "us-east-1"}`

only deviation, Did not pass `credential_profile_name:` as it is in the same region. and is optional as per documentation.

---

<div class="post-metadata">

**Author:** ![legoguy1000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/legoguy1000/32/54301_2.png) [@legoguy1000](https://discuss.elastic.co/u/legoguy1000)\
**Post date:** [April 3, 2021, 2:48pm UTC](https://discuss.elastic.co/t/filebeat-initializing-error-for-s3/269137/5 "2021-04-03T14:48:41Z")

</div>

Glad I could help.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 1, 2021, 4:49pm UTC](https://discuss.elastic.co/t/filebeat-initializing-error-for-s3/269137/6 "2021-05-01T16:49:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
