# Filebeat installed on EulerOS server and trying to start the service but its failing. Please advise

**URL:** <https://discuss.elastic.co/t/filebeat-installed-on-euleros-server-and-trying-to-start-the-service-but-its-failing-please-advise/283427>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [September 6, 2021, 9:48am UTC](https://discuss.elastic.co/t/filebeat-installed-on-euleros-server-and-trying-to-start-the-service-but-its-failing-please-advise/283427 "2021-09-06T09:48:05Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Amit\_Johari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_johari/32/94198_2.png) [@Amit\_Johari](https://discuss.elastic.co/u/Amit_Johari)\
**Post date:** [September 6, 2021, 9:48am UTC](https://discuss.elastic.co/t/filebeat-installed-on-euleros-server-and-trying-to-start-the-service-but-its-failing-please-advise/283427/1 "2021-09-06T09:48:05Z")

</div>

OS version: EulerOS release 2.0 (SP8)

ARCH: Linux HOBB14-RK01-PROD-CN-01 4.19.36-vhulk1905.1.0.h276.eulerosv2r8.aarch64 #1 SMP Mon Apr 1 00:00:00 UTC 2019 aarch64 aarch64 aarch64 GNU/Linux

Error:

[root@HOBB14-RK01-PROD-CN-01 home]# rpm -vi filebeat-7.8.0-x86\_64.rpm  
warning: filebeat-7.8.0-x86\_64.rpm: Header V4 RSA/SHA512 Signature, key ID d88e42b4: NOKEY  
Verifying packages...  
Preparing packages...  
package filebeat-7.8.0-1.x86\_64 is intended for a different architecture

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 6, 2021, 10:04am UTC](https://discuss.elastic.co/t/filebeat-installed-on-euleros-server-and-trying-to-start-the-service-but-its-failing-please-advise/283427/2 "2021-09-06T10:04:11Z")

</div>

Welcome to our community! 😃

> [@Amit\_Johari](#):
>
> aarch64

That's your OS.

> [@Amit\_Johari](#):
>
> x86\_64

That's your package.

They are not compatible. You will need the aarch package instead.

---

<div class="post-metadata">

**Author:** ![Amit\_Johari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_johari/32/94198_2.png) [@Amit\_Johari](https://discuss.elastic.co/u/Amit_Johari)\
**Post date:** [September 6, 2021, 10:35am UTC](https://discuss.elastic.co/t/filebeat-installed-on-euleros-server-and-trying-to-start-the-service-but-its-failing-please-advise/283427/3 "2021-09-06T10:35:25Z")

</div>

Highly appreciated for quick response.

Which filebeat version or what we need to configure or install on this source machine ?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 6, 2021, 10:56am UTC](https://discuss.elastic.co/t/filebeat-installed-on-euleros-server-and-trying-to-start-the-service-but-its-failing-please-advise/283427/4 "2021-09-06T10:56:07Z")

</div>

You should be using latest where you can.

---

<div class="post-metadata">

**Author:** ![Amit\_Johari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_johari/32/94198_2.png) [@Amit\_Johari](https://discuss.elastic.co/u/Amit_Johari)\
**Post date:** [September 23, 2021, 8:50am UTC](https://discuss.elastic.co/t/filebeat-installed-on-euleros-server-and-trying-to-start-the-service-but-its-failing-please-advise/283427/5 "2021-09-23T08:50:25Z")

</div>

Issue is resolved now after installed filebeat-7.14.1-aarch64.rpm on server.

Thank you so much.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 21, 2021, 10:51am UTC](https://discuss.elastic.co/t/filebeat-installed-on-euleros-server-and-trying-to-start-the-service-but-its-failing-please-advise/283427/6 "2021-10-21T10:51:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
