# Filebeat is not starting when running the config file

**URL:** <https://discuss.elastic.co/t/filebeat-is-not-starting-when-running-the-config-file/129826>\
**Category:** Beats\
**Created:** [April 27, 2018, 12:11pm UTC](https://discuss.elastic.co/t/filebeat-is-not-starting-when-running-the-config-file/129826 "2018-04-27T12:11:26Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Akash\_Tanwar](https://avatars.discourse-cdn.com/v4/letter/a/3ab097/32.png) [@Akash\_Tanwar](https://discuss.elastic.co/u/Akash_Tanwar)\
**Post date:** [April 27, 2018, 12:11pm UTC](https://discuss.elastic.co/t/filebeat-is-not-starting-when-running-the-config-file/129826/1 "2018-04-27T12:11:26Z")

</div>

Hi, I am very new to ELK and trying to run filebeat for logstash out but my config file of filebeat is not working. Can some one please help me out on this?

filebeat config:

filebeat.prospectors:

- input\_type: log  
paths:
  - /var/log/access-22.log

output.logstash:  
hosts : ["localhost:5044"]

filebeat.yml:  
#=========================== Filebeat prospectors =============================

filebeat.prospectors:

# Each - is a prospector. Most options can be set at the prospector level, so

# you can use different prospectors for various configurations.

# Below are the prospector specific configurations.

- type: log

#============================= Filebeat modules ===============================

filebeat.config.modules:

# Glob pattern for configuration loading

path: ${path.config}/modules.d/\*.yml

# Set to true to enable config reloading

reload.enabled: false

# Period on which files under path should be checked for changes

#reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:  
index.number\_of\_shards: 3  
#index.codec: best\_compression  
#\_source.enabled: false

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group

# all the transactions sent by a single shipper in the web interface.

#name:

# The tags of the shipper are included in their own field with each

# transaction published.

#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the

# output.

#fields:

# env: staging

#============================== Dashboards =====================================

# These settings control loading the sample dashboards to the Kibana index. Loading

# the dashboards is disabled by default and can be enabled either by setting the

# options here, or by using the `-setup` CLI flag or the `setup` command.

#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL

# has a value which is computed based on the Beat name and version. For released

# versions, this URL points to the dashboard archive on the [artifacts.elastic.co](http://artifacts.elastic.co)

# website.

#setup.dashboards.url:

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.

# This requires a Kibana endpoint configuration.

setup.kibana:

# Kibana Host

# Scheme and port can be left out and will be set to the default (http and 5601)

# In case you specify and additional path, the scheme is required: [http://localhost:5601/path](http://localhost:5601/path)

# IPv6 addresses should always be defined as: https://[2001:db8::1]:5601

#host: "localhost:5601"

#============================= Elastic Cloud ==================================

# These settings simplify using filebeat with the Elastic Cloud ([https://cloud.elastic.co/](https://cloud.elastic.co/)).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and

# `setup.kibana.host` options.

# You can find the `cloud.id` in the Elastic Cloud web UI.

#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and

# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.

#cloud.auth:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------  
#output.elasticsearch:

# Array of hosts to connect to.

#hosts: ["localhost:9200"]

# Optional protocol and basic auth credentials.

#protocol: "https"  
#username: "elastic"  
#password: "changeme"

#----------------------------- Logstash output --------------------------------  
output.logstash:

# The Logstash hosts

hosts: ["localhost:5044"]

# Optional SSL. By default is off.

# List of root certificates for HTTPS server verifications

#ssl.certificate\_authorities: ["/etc/pki/root/ca.pem"]

# Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

# Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"

#================================ Logging =====================================

# Sets log level. The default log level is info.

# Available log levels are: error, warning, info, debug

#logging.level: debug

# At debug level, you can selectively enable logging only for some components.

# To enable all selectors use ["\*"]. Examples of other selectors are "beat",

# "publish", "service".

#logging.selectors: ["\*"]

ERROR:

2018-04-27 17:24:55.896782011 +0530 IST m=+0.020098188 write error: failed to rotate backups: rename /usr/share/filebeat/bin/logs/filebeat /usr/share/filebeat/bin/logs/filebeat.1: permission denied  
2018-04-27 17:24:55.896884396 +0530 IST m=+0.020200538 write error: failed to rotate backups: rename /usr/share/filebeat/bin/logs/filebeat /usr/share/filebeat/bin/logs/filebeat.1: permission denied  
Exiting: Failed to create Beat meta file: open /usr/share/filebeat/bin/data/meta.json.new: permission denied

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [April 27, 2018, 12:46pm UTC](https://discuss.elastic.co/t/filebeat-is-not-starting-when-running-the-config-file/129826/2 "2018-04-27T12:46:21Z")

</div>

Please format your config using `</>`.

How did you install Filebeat? Is it installed from the official repositories? Which version are you running?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 25, 2018, 2:46pm UTC](https://discuss.elastic.co/t/filebeat-is-not-starting-when-running-the-config-file/129826/3 "2018-05-25T14:46:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
