# Filebeat kept reporting "read: connection reset by peer" error

**URL:** https://discuss.elastic.co/t/filebeat-kept-reporting-read-connection-reset-by-peer-error/82157
**Category:** Beats
**Tags:** filebeat
**Created:** [April 12, 2017, 12:13pm UTC](https://discuss.elastic.co/t/filebeat-kept-reporting-read-connection-reset-by-peer-error/82157 "2017-04-12T12:13:56Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Daniel\_Chen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/daniel_chen/32/17288_2.png) [@Daniel\_Chen](https://discuss.elastic.co/u/Daniel_Chen)
#### Post date: [April 12, 2017, 12:13pm UTC](https://discuss.elastic.co/t/filebeat-kept-reporting-read-connection-reset-by-peer-error/82157/1 "2017-04-12T12:13:56Z")

</div>

I am new to ELK, and I have:

- Elasticsearch 5.3.0
- Kibana 5.3.0
- Logstash 1:5.3.0
- Filebeat 5.3.0

**filebeat.yml**

```auto
filebeat:
  prospectors:
    -
      paths:
        - /${BASEPATH}/nginx-logs/*.log

      input_type: log

      document_type: nginx-access
      #harvester_limit: 500
      #close_eof: true
      #ignore_older: 1h

  registry_file: /var/lib/filebeat/registry

output:
  logstash:
    hosts: ["${Logstash_Server}:5044"]
    bulk_max_size: 1024

    tls:
      certificate_authorities: ["/etc/pki/tls/certs/logstash-forwarder.crt"]

shipper:

logging:
  logging.level: warning
  logging.to_files: true
  logging.to_syslog: false
  logging.files:
    path: /var/log/mybeat
    name: mybeat.log
    keepfiles: 7

```

**logstash/conf.d/02-beats-input.conf**

```auto
input {
  beats {
    port => 5044
    ssl => true
    ssl_certificate => "/etc/pki/tls/certs/logstash-forwarder.crt"
    ssl_key => "/etc/pki/tls/private/logstash-forwarder.key"
  }
}

```

**logstash/conf.d/11-nginx-filter.conf**

```auto
filter {
  if [type] == "nginx-access" {
    grok {
      match => { "message" => "%{NGINXACCESS}" }
      overwrite => ["message"]
    }
  }
}

```

And I'm getting error message:

```auto
2017-04-12T20:08:30+08:00 INFO No non-zero metrics in the last 30s
2017-04-12T20:08:47+08:00 ERR Failed to publish events caused by: read tcp 10.0.3.200:48134->10.0.6.35:5044: read: connection reset by peer
2017-04-12T20:08:47+08:00 INFO Error publishing events (retrying): read tcp 10.0.3.200:48134->10.0.6.35:5044: read: connection reset by peer
2017-04-12T20:09:00+08:00 INFO Non-zero metrics in the last 30s: libbeat.logstash.call_count.PublishEvents=1 libbeat.logstash.publish.read_errors=1 libbeat.logstash.publish.write_bytes=419 libbeat.logstash.published_but_not_acked_events=102
4

```

any ideas?

---

<div class="post-metadata">

### Author: ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)
#### Post date: [April 12, 2017, 2:26pm UTC](https://discuss.elastic.co/t/filebeat-kept-reporting-read-connection-reset-by-peer-error/82157/2 "2017-04-12T14:26:47Z")

</div>

In your Filebeat configuration try changing `tls` to `ssl`. See the list of [breaking changes](https://www.elastic.co/guide/en/beats/libbeat/5.3/breaking-changes-5.0.html) between 1.x and 5.x.

---

<div class="post-metadata">

### Author: ![Daniel\_Chen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/daniel_chen/32/17288_2.png) [@Daniel\_Chen](https://discuss.elastic.co/u/Daniel_Chen)
#### Post date: [April 13, 2017, 3:04am UTC](https://discuss.elastic.co/t/filebeat-kept-reporting-read-connection-reset-by-peer-error/82157/3 "2017-04-13T03:04:13Z")

</div>

Thanks, after change `tls` to `ssl` it works.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 11, 2017, 3:06am UTC](https://discuss.elastic.co/t/filebeat-kept-reporting-read-connection-reset-by-peer-error/82157/4 "2017-05-11T03:06:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
