# Filebeat & Kibana error: "Visualize: Fielddata is disabled on text fields by default."

**URL:** https://discuss.elastic.co/t/filebeat-kibana-error-visualize-fielddata-is-disabled-on-text-fields-by-default/71678
**Category:** Kibana
**Created:** [January 16, 2017, 6:34am UTC](https://discuss.elastic.co/t/filebeat-kibana-error-visualize-fielddata-is-disabled-on-text-fields-by-default/71678 "2017-01-16T06:34:07Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![rootameen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rootameen/32/14470_2.png) [@rootameen](https://discuss.elastic.co/u/rootameen)
#### Post date: [January 16, 2017, 6:34am UTC](https://discuss.elastic.co/t/filebeat-kibana-error-visualize-fielddata-is-disabled-on-text-fields-by-default/71678/1 "2017-01-16T06:34:07Z")

</div>

Hi guys,  
I recently started a new setup of ELK stack based on version 5.1. Everything went smoothly except for the visualization section on Kibana. Whenever I try to create something (like a visual of beat.name), I get the error message:

> Visualize: Fielddata is disabled on text fields by default. Set fielddata=true on [beat.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory.

I'm currently using filebeat to ship all my log messages, and I've checked the official documentation and came across this link: [fielddata | Elasticsearch Guide [5.0] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/5.0/fielddata.html)

I tried to apply it on my setup but I just can't figure out what exactly to put in the curl statement to reflect this change on logs. What should I relpace "/my\_index/\_mapping/my\_type" with?

I appreciate your help.

Thanks.

---

<div class="post-metadata">

### Author: ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)
#### Post date: [January 20, 2017, 9:04pm UTC](https://discuss.elastic.co/t/filebeat-kibana-error-visualize-fielddata-is-disabled-on-text-fields-by-default/71678/2 "2017-01-20T21:04:59Z")

</div>

> I'm currently using filebeat to ship all my log messages, and I've checked the official documentation and came across this link: [fielddata | Elasticsearch Guide [5.0] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/5.0/fielddata.html)

Check the [Filebeat documentation](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-template.html), and you will find that you can control the mapping template from Filebeat by updating `filebeat.template.json`. That will give you an assistance in having it work from the start, but it only applies if you are using the `output.elasticsearch` option in Filebeat. If you are shipping your beats to Logstash, check the [Logstash documentation](https://www.elastic.co/guide/en/logstash/current/plugins-outputs-elasticsearch.html#plugins-outputs-elasticsearch-template) on the template setting to the Elasticsearch output.

> [@rootameen](#):
>
> What should I relpace "/my\_index/\_mapping/my\_type" with?

I recommend setting up your Filebeat or Elasticsearch to load the index template before you start indexing documents, because you can't change the mapping for existing documents in Elasticsearch.

If you want to use `curl` to do this, the new mapping will apply the next time you create a new index with the index pattern, i.e. when daily rotation creates a new index with a new timestamp in the name. You replace `/my_index/_mapping/my_type` with the name of your index and type. Look at one of your documents in Discover in Kibana, and in the Table view or JSON view, those names will be the `_index` and `_type` fields.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 17, 2017, 9:05pm UTC](https://discuss.elastic.co/t/filebeat-kibana-error-visualize-fielddata-is-disabled-on-text-fields-by-default/71678/3 "2017-02-17T21:05:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
