# コンテナ上のfilebeatのlogging.to\_syslog設定について

**URL:** <https://discuss.elastic.co/t/filebeat-logging-to-syslog/200409>\
**Category:** 日本語による質問・議論はこちら\
**Created:** [September 20, 2019, 12:17pm UTC](https://discuss.elastic.co/t/filebeat-logging-to-syslog/200409 "2019-09-20T12:17:34Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Negi700](https://avatars.discourse-cdn.com/v4/letter/n/e9bcb4/32.png) [@Negi700](https://discuss.elastic.co/u/Negi700)\
**Post date:** [September 20, 2019, 12:17pm UTC](https://discuss.elastic.co/t/filebeat-logging-to-syslog/200409/1 "2019-09-20T12:17:34Z")

</div>

コンテナ上のfilebeatのアプリログをsyslogに出力させたいです。  
コンテナ上のfilebeatのため、「logging.to\_syslog: true」で設定すると、  
下記syslog系のエラーが出てアプリログが出力されません。

対処方法を教えていただけないでしょうか？

filebeatの設定  
logging.to\_syslog: true

エラー出力  
Exiting: error initializing logging: failed to build log output: failed to get a syslog writer: Unix syslog delivery error

---

<div class="post-metadata">

**Author:** ![tsgkdt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsgkdt/32/39151_2.png) [@tsgkdt](https://discuss.elastic.co/u/tsgkdt)\
**Post date:** [September 24, 2019, 6:48am UTC](https://discuss.elastic.co/t/filebeat-logging-to-syslog/200409/2 "2019-09-24T06:48:14Z")

</div>

こんにちわ

**コンテナの中では** 、rsyslogといったサービスが動いていないと思うので、syslogに出力しようとすると提示いただいたようなエラーになるのだと思います。

参考例

> **[quotunix syslog delivery errorquot in debian docker image tutel.me | tutel.me](https://tutel.me/c/programming/questions/49389972/quotunix+syslog+delivery+errorquot+in+debian+docker+image)**
>
> \[SOLVED\] "Unix syslog delivery error" in debian docker image | I am getting error "Unix syslog delivery error" when i run my docker image through kubernetes.
> My dockerfile looks like this.
> 
> FROM debian:jessie
> EXPOSE 3307
> COPY maven /abc/
> WORKDIR...

上記URLにあるように、`service rsyslog start`としたあとに、filebeatを動かすとエラーが解消されるはずです。

さて、蛇足ながらコンテナの中でfilebeatが出力したログを、 **ホスト側のsyslog** に出力したいという場合でしたら、コンテナの中でsyslogに出さなくても、dockerのログドライバをsyslogにすることで対応できるかと思います。

- コンテナ起動時にログドライバをsyslogを指定する `docker run --log-driver=syslog ～`

こうしておくことで、コンテナ内のfilebeatが標準出力にログを出力すると、ホスト側ではsyslogにログが溜まっていきます。

ご参考になれば幸いです。

---

<div class="post-metadata">

**Author:** ![Negi700](https://avatars.discourse-cdn.com/v4/letter/n/e9bcb4/32.png) [@Negi700](https://discuss.elastic.co/u/Negi700)\
**Post date:** [September 25, 2019, 1:40am UTC](https://discuss.elastic.co/t/filebeat-logging-to-syslog/200409/3 "2019-09-25T01:40:31Z")

</div>

こんにちは

助かりました。  
ご教示、ありがとうございます。

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 23, 2019, 1:40am UTC](https://discuss.elastic.co/t/filebeat-logging-to-syslog/200409/4 "2019-10-23T01:40:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
