# Filebeat -\> Logstash Connection ISSUE

**URL:** <https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181>\
**Category:** Logstash\
**Created:** [July 12, 2019, 9:07am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181 "2019-07-12T09:07:25Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sundaramoorthy\_Anand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sundaramoorthy_anand/32/47787_2.png) [@Sundaramoorthy\_Anand](https://discuss.elastic.co/u/Sundaramoorthy_Anand)\
**Post date:** [July 12, 2019, 9:07am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/1 "2019-07-12T09:07:26Z")

</div>

My ELK is in a server of **`xyzcorp.com`** of IP **`16.xxx.xxx.xxx`** and filebeat is in **`xyz.com`** of IP **`16.aaa.aaa.aaa`**

Both are in different domains but in same intranet umbrella.

In **`filebeat.yml`** , I'm enabling the output.logstash

```
- type: log
  enabled: true

  paths:
    - /path/to/*.log

output.logstash:
      # The Logstash hosts
      hosts: ["16.xxx.xxx.xxx:5044"]

```

and in **`logstash.config`** ,

```
input {
        beats {
                type => beats
                port => 5044
                host => "16.xxx.xxx.xxx"
        }
}

```

and **`logstash.yml`** is unchanged

What is going wrong? I dont know!  
**`Giving the following error:`**

```
  2019-07-12T06:57:20.928Z ERROR pipeline/output.go:100 Failed to connect to backoff(async(tcp://16.xxx.xxx.xxx:5044)): dial tcp 16.xxx.xxx.xxx:5044: i/o timeout
  2019-07-12T06:57:20.929Z INFO pipeline/output.go:93 Attempting to reconnect to backoff(async(tcp://16.xxx.xxx.xxx:5044)) with 2 reconnect attempt(s)
```

---

<div class="post-metadata">

**Author:** ![harshbajaj16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/harshbajaj16/32/44970_2.png) [@harshbajaj16](https://discuss.elastic.co/u/harshbajaj16)\
**Post date:** [July 12, 2019, 9:33am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/2 "2019-07-12T09:33:34Z")

</div>

Hi @Sundaramoorthy_Anand,

Please check the below following points:  
Are you able to do telnet or ping the host??  
Are the port open or any rule??

Regards,  
Harsh Bajaj

---

<div class="post-metadata">

**Author:** ![Sundaramoorthy\_Anand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sundaramoorthy_anand/32/47787_2.png) [@Sundaramoorthy\_Anand](https://discuss.elastic.co/u/Sundaramoorthy_Anand)\
**Post date:** [July 12, 2019, 10:33am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/3 "2019-07-12T10:33:28Z")

</div>

Yes **`ping`** is working and **`telnet to port 22/23/5044`** is giving **`connection timed out error`**.

Where to see those port rules? **`Firewalld service is NOT running`** in the servers, actually.

---

<div class="post-metadata">

**Author:** ![harshbajaj16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/harshbajaj16/32/44970_2.png) [@harshbajaj16](https://discuss.elastic.co/u/harshbajaj16)\
**Post date:** [July 12, 2019, 11:23am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/4 "2019-07-12T11:23:15Z")

</div>

Hi @Sundaramoorthy_Anand,

Its look like there is some blockage on port. However you said that firewalld is not running.

> [@Sundaramoorthy\_Anand](#):
>
> **`telnet to port 22/23/5044`** is giving **`connection timed out error`**.

---

<div class="post-metadata">

**Author:** ![Sundaramoorthy\_Anand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sundaramoorthy_anand/32/47787_2.png) [@Sundaramoorthy\_Anand](https://discuss.elastic.co/u/Sundaramoorthy_Anand)\
**Post date:** [July 12, 2019, 11:28am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/5 "2019-07-12T11:28:22Z")

</div>

Changing it to a different port will give any improvement?

---

<div class="post-metadata">

**Author:** ![harshbajaj16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/harshbajaj16/32/44970_2.png) [@harshbajaj16](https://discuss.elastic.co/u/harshbajaj16)\
**Post date:** [July 12, 2019, 11:31am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/6 "2019-07-12T11:31:24Z")

</div>

Could you please share the telnet command which you are running on your machine.

Actually, we need find the problem first and i don't think so changing port will give any result.

> [@Sundaramoorthy\_Anand](#):
>
> Changing it to a different port will give any improvement?

Regards,  
Harsh Bajaj

---

<div class="post-metadata">

**Author:** ![Sundaramoorthy\_Anand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sundaramoorthy_anand/32/47787_2.png) [@Sundaramoorthy\_Anand](https://discuss.elastic.co/u/Sundaramoorthy_Anand)\
**Post date:** [July 12, 2019, 11:38am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/7 "2019-07-12T11:38:25Z")

</div>

```
telnet <ip> 5044
Trying <ip>...
telnet: connect to address <ip>: Connection timed out

```

I also tried with other ports like 22 and 23 results in same ERROR

---

<div class="post-metadata">

**Author:** ![harshbajaj16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/harshbajaj16/32/44970_2.png) [@harshbajaj16](https://discuss.elastic.co/u/harshbajaj16)\
**Post date:** [July 15, 2019, 4:02am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/8 "2019-07-15T04:02:00Z")

</div>

Hi @Sundaramoorthy_Anand,

There may be some problem or blockage with your firewall setting.

Regards,  
Harsh Bajaj

---

<div class="post-metadata">

**Author:** ![Sundaramoorthy\_Anand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sundaramoorthy_anand/32/47787_2.png) [@Sundaramoorthy\_Anand](https://discuss.elastic.co/u/Sundaramoorthy_Anand)\
**Post date:** [July 16, 2019, 6:16am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/9 "2019-07-16T06:16:03Z")

</div>

Any comments on Filebeat and Logstash on different domains but on same data center umbrella?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 13, 2019, 6:16am UTC](https://discuss.elastic.co/t/filebeat-logstash-connection-issue/190181/10 "2019-08-13T06:16:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
