# Filebeat make update fails for new custom module

**URL:** <https://discuss.elastic.co/t/filebeat-make-update-fails-for-new-custom-module/277578>\
**Category:** Beats\
**Tags:** docker, beats-module\
**Created:** [July 1, 2021, 4:20pm UTC](https://discuss.elastic.co/t/filebeat-make-update-fails-for-new-custom-module/277578 "2021-07-01T16:20:21Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jerry\_Tian](https://avatars.discourse-cdn.com/v4/letter/j/b38774/32.png) [@Jerry\_Tian](https://discuss.elastic.co/u/Jerry_Tian)\
**Post date:** [July 1, 2021, 4:20pm UTC](https://discuss.elastic.co/t/filebeat-make-update-fails-for-new-custom-module/277578/1 "2021-07-01T16:20:21Z")

</div>

I followed the instructions from here: [Creating a New Filebeat Module | Beats Developer Guide [master] | Elastic](https://www.elastic.co/guide/en/beats/devguide/current/filebeat-modules-devguide.html).

```auto
make create-module MODULE={module}
make create-fileset MODULE={module} FILESET={fileset}
make create-fields MODULE={module} FILESET={fileset}

```

All the commands above worked except for make update.

This is what I see when I run make update in cmd

```auto
mage update
>> Building filebeat.yml for linux/amd64
>> Building filebeat.reference.yml for linux/amd64
>> Building filebeat.docker.yml for linux/amd64
warn: failed to upgrade pip (ignoring): failed to run "/home/jerry/go/src/github.com/elastic/beats/build/ve/linux/bin/pip install -U pip: fork/exec /home/jerry/go/src/github.com/elastic/beats/build/ve/linux/bin/pip: no such file or directory"Makefile:13: recipe for target 'update' failed

```

Any help will be appreciated

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 29, 2021, 6:20pm UTC](https://discuss.elastic.co/t/filebeat-make-update-fails-for-new-custom-module/277578/2 "2021-07-29T18:20:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
