# Filebeat Mysql Module dashboard - No results found

**URL:** <https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [May 14, 2018, 1:29pm UTC](https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749 "2018-05-14T13:29:05Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Milad\_Hamid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/milad_hamid/32/24327_2.png) [@Milad\_Hamid](https://discuss.elastic.co/u/Milad_Hamid)\
**Post date:** [May 14, 2018, 1:29pm UTC](https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749/1 "2018-05-14T13:29:06Z")

</div>

Hi,

I installed Filebeat 6.2 and enabled Mysql module to monitor our MariaDB / Mysql server. I configured filebeat.yml and mysql.yml as following:

filebeat.yml

```
filebeat.prospectors:

- type: log
  fields.logtype: "MariaDBerror"
  enabled: true
  paths:
    - C:\Program Files\MariaDB 10.2\data\LAPTOP-milad-slow.log
    - C:\Program Files\MariaDB 10.2\data\LAPTOP-milad.err
  multiline.pattern: '^\#####'
  multiline.negate: true
  multiline.match: after
#============================= Filebeat modules ===============================
filebeat.config.modules:
  #path: ${path.config}/modules.d/*.yml
  path: C:\ProgramData\Elastic\filebeat\modules.d\mysql.yml
  reload.enabled: true
#==================== Elasticsearch template setting ==========================
setup.template.settings:
    index.number_of_shards: 3
#============================== Dashboards =====================================
setup.dashboards.enabled: true
#============================== Kibana =====================================
setup.kibana:
  host: "localhost:5601"
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
   hosts: ["localhost:9200"]

```

filebeat\modules.d\mysql.yml

```
- module: mysql
  # Error logs
  error:
    enabled: true
    var.paths: 'C:\Program Files\MariaDB 10.2\data\LAPTOP-milad.err'
    
  # Slow logs
  slowlog:
    enabled: true
    var.paths: 'C:\Program Files\MariaDB 10.2\data\LAPTOP-milad-slow.log'

```

So in Kibana when i open Filebeat Mysql Overview dashboard it shows no results found.  
I got events in discover page so my filebeat sending logs to the elasticsearch and i see them in discover page.

I used [http://www.yamllint.com/](http://www.yamllint.com/) to check errors with mysql.yml file, and it seems ok.

Appreciate help with this.

---

<div class="post-metadata">

**Author:** ![jsoriano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsoriano/32/27920_2.png) [@jsoriano](https://discuss.elastic.co/u/jsoriano)\
**Post date:** [May 14, 2018, 4:14pm UTC](https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749/2 "2018-05-14T16:14:01Z")

</div>

Hi @Milad_Hamid,

Indeed if the logs appear in the discovery page they should also appear in the dashboards. Can you check if the logs you see in discover are the ones created by mysql filebeat module? (They should have the `fileset.name` field set to `mysql`).

---

<div class="post-metadata">

**Author:** ![Milad\_Hamid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/milad_hamid/32/24327_2.png) [@Milad\_Hamid](https://discuss.elastic.co/u/Milad_Hamid)\
**Post date:** [May 15, 2018, 1:21pm UTC](https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749/3 "2018-05-15T13:21:30Z")

</div>

Hi @jsoriano and thanks for reply.

> [@jsoriano](#):
>
> Can you check if the logs you see in discover are the ones created by mysql filebeat module? (They should have the fileset.name field set to mysql).

I need your help with this how i can check if it is created by Mysql Module ? because what i am seeing now in elasticsearch the default filebeat index. So i don't know if logs in discover created by filebeat mysql module!

but in Powershell i tried ` ./filebeat -e` then shut down the MySQL server to get some logs, so i could see this error show up in Powershell by running ` ./filebeat -e` :

`2018-05-15T15:16:51.252+0200 ERROR cfgfile/reload.go:206 Unable to create runner due to error: Error getting config for fielset mysql/error: Error interpreting the template of the prospector: template: text:3:22: executing "text" at <.paths>: range can't iterate over C:\Program Files\MariaDB 10.2\data\LAPTOP-milad.err`

---

<div class="post-metadata">

**Author:** ![jsoriano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsoriano/32/27920_2.png) [@jsoriano](https://discuss.elastic.co/u/jsoriano)\
**Post date:** [May 15, 2018, 1:36pm UTC](https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749/4 "2018-05-15T13:36:41Z")

</div>

Oh, I see in the error, `var.paths` must be set as an array, try this configuration:

```auto
- module: mysql
  # Error logs
  error:
    enabled: true
    var.paths:
      - 'C:\Program Files\MariaDB 10.2\data\LAPTOP-milad.err'
    
  # Slow logs
  slowlog:
    enabled: true
    var.paths:
      - 'C:\Program Files\MariaDB 10.2\data\LAPTOP-milad-slow.log'

```

---

<div class="post-metadata">

**Author:** ![Milad\_Hamid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/milad_hamid/32/24327_2.png) [@Milad\_Hamid](https://discuss.elastic.co/u/Milad_Hamid)\
**Post date:** [May 15, 2018, 8:34pm UTC](https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749/5 "2018-05-15T20:34:30Z")

</div>

Thanks 🙂, i will test it and post the feedback.

---

<div class="post-metadata">

**Author:** ![Milad\_Hamid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/milad_hamid/32/24327_2.png) [@Milad\_Hamid](https://discuss.elastic.co/u/Milad_Hamid)\
**Post date:** [May 16, 2018, 6:42am UTC](https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749/6 "2018-05-16T06:42:26Z")

</div>

@jsoriano yes that was the solution and in addition i stopped running `./filebeat -e` in Powershell because i think it will reload the module, so it works 🙂  
Thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 13, 2018, 6:42am UTC](https://discuss.elastic.co/t/filebeat-mysql-module-dashboard-no-results-found/131749/7 "2018-06-13T06:42:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
