# Filebeat not sending docker logs to logstash after enabling x-pack security features

**URL:** <https://discuss.elastic.co/t/filebeat-not-sending-docker-logs-to-logstash-after-enabling-x-pack-security-features/343100>\
**Category:** Beats\
**Tags:** docker, filebeat\
**Created:** [September 15, 2023, 5:02am UTC](https://discuss.elastic.co/t/filebeat-not-sending-docker-logs-to-logstash-after-enabling-x-pack-security-features/343100 "2023-09-15T05:02:01Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ajai\_Raj](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ajai_raj/32/122141_2.png) [@Ajai\_Raj](https://discuss.elastic.co/u/Ajai_Raj)\
**Post date:** [September 15, 2023, 5:02am UTC](https://discuss.elastic.co/t/filebeat-not-sending-docker-logs-to-logstash-after-enabling-x-pack-security-features/343100/1 "2023-09-15T05:02:01Z")

</div>

Please help me in this i've been trying to create a user in ELK after enabling the x-pack security feature in my elasticsearch.yml file. The docker container logs are not syncing in kibana after i enable the security feature, If i disable the x-pack the logs are syncing again.

This is the log i get in filebeat.  
"filebeat.service: Failed with result 'exit-code'."  
"Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch"

Please let me know you need anything else.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 13, 2023, 7:02am UTC](https://discuss.elastic.co/t/filebeat-not-sending-docker-logs-to-logstash-after-enabling-x-pack-security-features/343100/2 "2023-10-13T07:02:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
