# Filebeat not starting

**URL:** <https://discuss.elastic.co/t/filebeat-not-starting/263076>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 3, 2021, 6:45am UTC](https://discuss.elastic.co/t/filebeat-not-starting/263076 "2021-02-03T06:45:20Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Kaushal\_Kishore1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaushal_kishore1/32/83341_2.png) [@Kaushal\_Kishore1](https://discuss.elastic.co/u/Kaushal_Kishore1)\
**Post date:** [February 3, 2021, 6:45am UTC](https://discuss.elastic.co/t/filebeat-not-starting/263076/1 "2021-02-03T06:45:20Z")

</div>

my filebeat.yaml

filebeat.inputs:  
- type: log  
paths:  
- /var/log/apache2/whatfix\_access.log  
tags: ["apache"]

```
- type: log
  paths:
    - /usr/lib/quickonutch/logs/quickoapi.20*
  tags: ["api"]
  multiline.pattern: '^[[:space:]]|^Caused by:'
  multiline.negate: false
  multiline.match: after

- type: log
  paths:
    - /var/log/redis/*.log
  tags: ["redis"]
  multiline.match: after

- type: log
  paths:
    - /var/log/cassandra/system.log
  tags: ["cassandra"]
  multiline.pattern: '^ '
  multiline.negate: true
  multiline.match: after

```

output.logstash:  
hosts: [""]  
index: logstash  
~

When I am trying to restart filebeat it fails with exit-code.  
Exiting: Error while initializing input: missing required field accessing 'filebeat.inputs.2.multiline.pattern' (source:'/etc/filebeat/filebeat.yml')

What am i missing?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 3, 2021, 8:46am UTC](https://discuss.elastic.co/t/filebeat-not-starting/263076/2 "2021-03-03T08:46:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
