# Filebeat prospector configuration files aren't recognized with .yaml suffix

**URL:** <https://discuss.elastic.co/t/filebeat-prospector-configuration-files-arent-recognized-with-yaml-suffix/217259>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 30, 2020, 6:24pm UTC](https://discuss.elastic.co/t/filebeat-prospector-configuration-files-arent-recognized-with-yaml-suffix/217259 "2020-01-30T18:24:10Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![PMDubuc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pmdubuc/32/91628_2.png) [@PMDubuc](https://discuss.elastic.co/u/PMDubuc)\
**Post date:** [January 30, 2020, 6:24pm UTC](https://discuss.elastic.co/t/filebeat-prospector-configuration-files-arent-recognized-with-yaml-suffix/217259/1 "2020-01-30T18:24:10Z")

</div>

Using Filebeat 5.6.14 we've noticed that it ignores prospector configuration files that are kept in a separate directory if they have the official ".yaml" name extension instead of ".yml". The shorter one is commonly used, but should both be accepted since the longer one is preferred? (See [https://yaml.org/faq.html](https://yaml.org/faq.html)). It took us a while to figure out why this wasn't working since Filebeat doesn't give an error and just acts like the files don't exist.

Has this been fixed in a more recent version of beats?

---

<div class="post-metadata">

**Author:** ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)\
**Post date:** [January 30, 2020, 10:53pm UTC](https://discuss.elastic.co/t/filebeat-prospector-configuration-files-arent-recognized-with-yaml-suffix/217259/2 "2020-01-30T22:53:46Z")

</div>

Hi @PMDubuc, thanks for posting here. What's the file name for the prospector config? I think prospector is replaced by the concept of input. I did try on the latest Filebeat with filebeat.yaml instead of filebeat.yml. It showed error: `Exiting: error loading config file: stat filebeat.yml: no such file or directory`.

---

<div class="post-metadata">

**Author:** ![PMDubuc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pmdubuc/32/91628_2.png) [@PMDubuc](https://discuss.elastic.co/u/PMDubuc)\
**Post date:** [January 31, 2020, 1:02pm UTC](https://discuss.elastic.co/t/filebeat-prospector-configuration-files-arent-recognized-with-yaml-suffix/217259/3 "2020-01-31T13:02:42Z")

</div>

Thank you. for your response. I think you get that error message because the -c argument to filebeat still specifies filebeat.yml instead of filebeat.yaml so changing only the filename and not the argument to filebeat causes the error. My problem was different. It's possible to specify prospector or input definitions in separate configuration files instead of the filebeat.yml file. In this case you use the config\_dir setting in filebeat.yml to specify the directory where these input definition files are located (see [https://www.elastic.co/guide/en/beats/filebeat/current/configuration-general-options.html#\_config\_dir](https://www.elastic.co/guide/en/beats/filebeat/current/configuration-general-options.html#_config_dir)). The problem is that these files must end in ".yml" instead of ".yaml" or they will be ignored with with an error saying that there are no inputs defined. Since ".yaml" is the preferred suffix for files containing YAML, I think it should also be valid.

---

<div class="post-metadata">

**Author:** ![PMDubuc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pmdubuc/32/91628_2.png) [@PMDubuc](https://discuss.elastic.co/u/PMDubuc)\
**Post date:** [January 31, 2020, 1:37pm UTC](https://discuss.elastic.co/t/filebeat-prospector-configuration-files-arent-recognized-with-yaml-suffix/217259/4 "2020-01-31T13:37:02Z")

</div>

I just noticed that this problem can apparently be solved in versions after 6.0 by using the filebeat.config.inputs section of the filebeat.yml file where it looks like you can specify a glob pattern for the files ([https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-configuration-reloading.html#load-input-config](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-configuration-reloading.html#load-input-config)). If that works then we can avoid the problem when we upgrade to the latest version.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 28, 2020, 1:37pm UTC](https://discuss.elastic.co/t/filebeat-prospector-configuration-files-arent-recognized-with-yaml-suffix/217259/5 "2020-02-28T13:37:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
