# Filebeat service not starting

**URL:** https://discuss.elastic.co/t/filebeat-service-not-starting/119892
**Category:** Beats
**Tags:** filebeat
**Created:** [February 14, 2018, 11:57pm UTC](https://discuss.elastic.co/t/filebeat-service-not-starting/119892 "2018-02-14T23:57:46Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![jiten](https://avatars.discourse-cdn.com/v4/letter/j/e9c0ed/32.png) [@jiten](https://discuss.elastic.co/u/jiten)
#### Post date: [February 14, 2018, 11:57pm UTC](https://discuss.elastic.co/t/filebeat-service-not-starting/119892/1 "2018-02-14T23:57:46Z")

</div>

i am trying to configure and install filebeat using salt on centos7 machine, code is running fine but when i am checking systemctl status filebeat it is showing below error.

[jbansal@stage1-servicenode1 files]$ sudo systemctl status filebeat  
● filebeat.service - filebeat  
Loaded: loaded (/usr/lib/systemd/system/filebeat.service; enabled; vendor preset: disabled)  
Active: failed (Result: start-limit) since Wed 2018-02-14 23:41:10 UTC; 15min ago  
Docs: [https://www.elastic.co/guide/en/beats/filebeat/current/index.html](https://www.elastic.co/guide/en/beats/filebeat/current/index.html)  
Process: 96783 ExecStart=/usr/share/filebeat/bin/filebeat -c /etc/filebeat/filebeat.yml -path.home /usr/share/filebeat -path.config /etc/filebeat -path.data /var/lib/filebeat -path.logs /var/log/filebeat (code=exited, status=2)  
Main PID: 96783 (code=exited, status=2)

Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) filebeat[96783]: /go/src/github.com/elastic/beats/vendor/github.com/spf13/cobra/command.go:785 +0x30e  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) filebeat[96783]: [github.com/elastic/beats/vendor/github.com/spf13/cobra.(\*Command](http://github.com/elastic/beats/vendor/github.com/spf13/cobra.(*Command)).Execute(0xc420350f00, 0xc42022bf70, 0x146a649)  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) filebeat[96783]: /go/src/github.com/elastic/beats/vendor/github.com/spf13/cobra/command.go:738 +0x2b  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) filebeat[96783]: main.main()  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) filebeat[96783]: /go/src/github.com/elastic/beats/filebeat/main.go:18 +0x2f  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) systemd[1]: filebeat.service holdoff time over, scheduling restart.  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) systemd[1]: start request repeated too quickly for filebeat.service  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) systemd[1]: Failed to start filebeat.  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) systemd[1]: Unit filebeat.service entered failed state.  
Feb 14 23:41:10 [stage1-servicenode1.aca1.tidemark.net](http://stage1-servicenode1.aca1.tidemark.net) systemd[1]: filebeat.service failed.

---

<div class="post-metadata">

### Author: ![exekias](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/exekias/32/28718_2.png) [@exekias](https://discuss.elastic.co/u/exekias)
#### Post date: [February 15, 2018, 8:20am UTC](https://discuss.elastic.co/t/filebeat-service-not-starting/119892/2 "2018-02-15T08:20:42Z")

</div>

Hi @jiten,

Do you have anything in the logs? They should be under `/var/log/filebeat` folder

Best regards

---

<div class="post-metadata">

### Author: ![jiten](https://avatars.discourse-cdn.com/v4/letter/j/e9c0ed/32.png) [@jiten](https://discuss.elastic.co/u/jiten)
#### Post date: [February 15, 2018, 4:40pm UTC](https://discuss.elastic.co/t/filebeat-service-not-starting/119892/3 "2018-02-15T16:40:04Z")

</div>

Hi Carlos,

thanks for your response, i figured it out and there was one small mistake in my jinja file and issue has been resolved for now. if there will be anything else i will let you know.

Thanks  
Jiten

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 15, 2018, 4:40pm UTC](https://discuss.elastic.co/t/filebeat-service-not-starting/119892/4 "2018-03-15T16:40:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
