# Filebeat service Start but not work, Error

**URL:** https://discuss.elastic.co/t/filebeat-service-start-but-not-work-error/117435
**Category:** Beats
**Tags:** filebeat
**Created:** [January 29, 2018, 10:32am UTC](https://discuss.elastic.co/t/filebeat-service-start-but-not-work-error/117435 "2018-01-29T10:32:17Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![omid](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/omid/32/33595_2.png) [@omid](https://discuss.elastic.co/u/omid)
#### Post date: [January 29, 2018, 10:32am UTC](https://discuss.elastic.co/t/filebeat-service-start-but-not-work-error/117435/1 "2018-01-29T10:32:17Z")

</div>

> 2018-01-29T13:59:37+03:30 INFO Non-zero metrics in the last 30s: beat.info.uptime.ms=30001 beat.memstats.gc\_next=10555920 beat.memstats.memory\_alloc=5393592 beat.memstats.memory\_total=19446152 filebeat.harvester.open\_files=4 filebeat.harvester.running=4 libbeat.config.module.running=0 libbeat.output.read.bytes=2003 libbeat.output.write.bytes=173 libbeat.pipeline.clients=1 libbeat.pipeline.events.active=4117 libbeat.pipeline.events.retry=2048 registrar.states.current=4

`

> 2018-01-29T14:00:12+03:30 ERR Failed to connect: x509: certificate is valid for [elk.mydomain.net](http://elk.mydomain.net), not [l-elk1.mydomain.net](http://l-elk1.mydomain.net)

`

---

<div class="post-metadata">

### Author: ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)
#### Post date: [January 29, 2018, 11:11am UTC](https://discuss.elastic.co/t/filebeat-service-start-but-not-work-error/117435/2 "2018-01-29T11:11:29Z")

</div>

It seems to me that you have certificate problems. You are trying to send to [l-elk1.mydomain.net](http://l-elk1.mydomain.net) and have the cert of [elk.mydomain.net](http://elk.mydomain.net). By changing your cert to the right one eliminates this problem.

If you need help on SSL, you can find more here: [https://www.elastic.co/guide/en/beats/filebeat/current/configuration-ssl.html](https://www.elastic.co/guide/en/beats/filebeat/current/configuration-ssl.html)

Let me know if you have further questions.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 26, 2018, 11:11am UTC](https://discuss.elastic.co/t/filebeat-service-start-but-not-work-error/117435/3 "2018-02-26T11:11:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
