# Filebeat service terminated unexpectedly - Windows server 2016

**URL:** https://discuss.elastic.co/t/filebeat-service-terminated-unexpectedly-windows-server-2016/198797
**Category:** Beats
**Tags:** filebeat
**Created:** [September 9, 2019, 10:03pm UTC](https://discuss.elastic.co/t/filebeat-service-terminated-unexpectedly-windows-server-2016/198797 "2019-09-09T22:03:37Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![scottk](https://avatars.discourse-cdn.com/v4/letter/s/db5fbb/32.png) [@scottk](https://discuss.elastic.co/u/scottk)
#### Post date: [September 9, 2019, 10:03pm UTC](https://discuss.elastic.co/t/filebeat-service-terminated-unexpectedly-windows-server-2016/198797/1 "2019-09-09T22:03:38Z")

</div>

Hi, my filebeat service will not run all of a sudden. Whenever I try to start the service, I get an error that "Error 1067: The process terminated unexpectedly". The event log provides no more details than that, besides Event ID 7034. It has been running just fine for a number of months up until now. No changes to the config file on the system, so not sure what could be the issue. A recent round of Windows patches has been applied - but we have removed that patch just to see of that was the culprit - no luck.

Looking into programdata\filebeat\logs doesn't seem to provide much helpful information either. Just a message about "Filebeat is unable to load the Ingest Node pipelines for the configured modules because the Elasticsearch output is not configured/enabled. If you have already loaded the Ingest Node pipelines or are using Logstash pipelines, you can ignore this warning." Since I am sending the logs to Logstash, I assume I can ignore that warning. After that error message from the log, it says  
\<INFO crawler/crawler.go:72 Loading Inputs: 1  
2019-09-09T15:47:35.020-0600 INFO crawler/crawler.go:106 Loading and starting Inputs completed. Enabled inputs: 0  
2019-09-09T15:47:35.020-0600 INFO cfgfile/reload.go:171 Config reloader started  
2019-09-09T15:47:35.027-0600 INFO cfgfile/reload.go:226 Loading of config files completed./\>

I've uninstalled the service, and reinstalled it from scratch, even recreated my yml config file. No change. If I start filebeat from the command line, it will run. But not as a service.

Any ideas what could be the issue?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 7, 2019, 10:03pm UTC](https://discuss.elastic.co/t/filebeat-service-terminated-unexpectedly-windows-server-2016/198797/2 "2019-10-07T22:03:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
