# Filebeat setup error

**URL:** <https://discuss.elastic.co/t/filebeat-setup-error/138247>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [July 2, 2018, 5:51pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247 "2018-07-02T17:51:57Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![eric\_Igbinosun](https://avatars.discourse-cdn.com/v4/letter/e/8baadc/32.png) [@eric\_Igbinosun](https://discuss.elastic.co/u/eric_Igbinosun)\
**Post date:** [July 2, 2018, 5:51pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247/1 "2018-07-02T17:51:58Z")

</div>

hello guys

getting up filebeat after installation when i run the filebeat setup cmd, i get this error.

Exiting: error loading config file: yaml : line 45: did not find '\_' indicator

is it because i have not setup kibana yet thats why i am getting this error

i look forward to your responce

thanks

---

<div class="post-metadata">

**Author:** ![adrisr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrisr/32/25423_2.png) [@adrisr](https://discuss.elastic.co/u/adrisr)\
**Post date:** [July 2, 2018, 6:12pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247/2 "2018-07-02T18:12:07Z")

</div>

This error means there is a problem with your `filebeat.yml`. Can you paste its contents here?

Enclose them in triple backticks

```  
like this  
```

---

<div class="post-metadata">

**Author:** ![eric\_Igbinosun](https://avatars.discourse-cdn.com/v4/letter/e/8baadc/32.png) [@eric\_Igbinosun](https://discuss.elastic.co/u/eric_Igbinosun)\
**Post date:** [July 3, 2018, 4:21pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247/4 "2018-07-03T16:21:39Z")

</div>

hello Adris

sorry for the late response

this is the filebeat.yml file

# options. The filebeat.reference.yml file from the same directory contains all the

# supported options with more comments. You can use it as a reference.

# 

# You can find the full configuration reference here:

# [https://www.elastic.co/guide/en/beats/filebeat/index.html](https://www.elastic.co/guide/en/beats/filebeat/index.html)

# For more available modules and options, please see the filebeat.reference.yml sample

# configuration file.

#=========================== Filebeat prospectors =============================

filebeat.prospectors:

# Each - is a prospector. Most options can be set at the prospector level, so

# you can use different prospectors for various configurations.

# Below are the prospector specific configurations.

- type: log

#============================= Filebeat modules ===============================

filebeat.config.modules:

# Glob pattern for configuration loading

path: ${path.config}/modules.d/\*.yml

# Set to true to enable config reloading

reload.enabled: false

# Period on which files under path should be checked for changes

#reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:  
index.number\_of\_shards: 3  
#index.codec: best\_compression  
#\_source.enabled: false

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group

# all the transactions sent by a single shipper in the web interface.

#name:

# The tags of the shipper are included in their own field with each

# transaction published.

#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the

# output.

#fields:

# env: staging

#============================== Dashboards =====================================

# These settings control loading

please review and let me know were i went wrong

thank you

---

<div class="post-metadata">

**Author:** ![adrisr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrisr/32/25423_2.png) [@adrisr](https://discuss.elastic.co/u/adrisr)\
**Post date:** [July 3, 2018, 5:37pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247/5 "2018-07-03T17:37:05Z")

</div>

@eric_Igbinosun

Please, when adding a configuration snippet to a forum post surround it with triple back-ticks:

```  
like this  
```

Or use the Blockquote button in the toolback.

Otherwise I can't help you because there is no way to detect indenting mistakes in the config

---

<div class="post-metadata">

**Author:** ![eric\_Igbinosun](https://avatars.discourse-cdn.com/v4/letter/e/8baadc/32.png) [@eric\_Igbinosun](https://discuss.elastic.co/u/eric_Igbinosun)\
**Post date:** [July 3, 2018, 5:40pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247/6 "2018-07-03T17:40:56Z")

</div>

sorry bout that

```auto
# options. The filebeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/filebeat/index.html

# For more available modules and options, please see the filebeat.reference.yml sample
# configuration file.

#=========================== Filebeat prospectors =============================

filebeat.prospectors:

# Each - is a prospector. Most options can be set at the prospector level, so
# you can use different prospectors for various configurations.
# Below are the prospector specific configurations.

- type: log

  # Change to true to enable this prospector configuration.
  enabled: false

  # Paths that should be crawled and fetched. Glob based paths.
  paths:
    - /opt/app1/logs/app1.log
    #- c:\programdata\elasticsearch\logs\*

  # Exclude lines. A list of regular expressions to match. It drops the lines that are
  # matching any regular expression from the list.
  #exclude_lines: ['^DBG']

  # Include lines. A list of regular expressions to match. It exports the lines that are
  # matching any regular expression from the list.
  #include_lines: ['^ERR', '^WARN']

  # Exclude files. A list of regular expressions to match. Filebeat drops the files that
  # are matching any regular expression from the list. By default, no files are dropped.
  #exclude_files: ['.gz$']

  # Optional additional fields. These fields can be freely picked
  # to add additional information to the crawled log files for filtering
  #fields:
    application: app1
  # review: 1

  ### Multiline options

  # Mutiline can be used for log messages spanning multiple lines. This is common
  # for Java Stack Traces or C-Line Continuation

  # The regexp Pattern that has to be matched. The example pattern matches all lines starting with [
  multiline.pattern: ^[[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2}

  # Defines if the pattern set under pattern should be negated or not. Default is false.
  multiline.negate: true

  # Match can be set to "after" or "before". It is used to define if lines should be append to a pattern
  # that was (not) matched before or after or as long as a pattern is not matched based on negate.
  # Note: After is the equivalent to previous and before is the equivalent to to next in Logstash
#============================= Filebeat modules ===============================

filebeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 3
  #index.codec: best_compression
  #_source.enabled: false

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
# env: staging

#============================== Dashboards =====================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here, or by using the `-setup` CLI flag or the `setup` command.
#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  #host: "localhost:5601"

#============================= Elastic Cloud ==================================
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

#----------------------------- Logstash output --------------------------------
#output.logstash:
  # The Logstash hosts
  #hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

#================================ Logging =====================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

#============================== Xpack Monitoring ===============================
# filebeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#xpack.monitoring.enabled: false

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well. Any setting that is not set is
# automatically inherited from the Elasticsearch output configuration, so if you
# have the Elasticsearch output configured, you can simply uncomment the
# following line.
-- INSERT -- 185,1 99%

```

hope this works

---

<div class="post-metadata">

**Author:** ![adrisr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adrisr/32/25423_2.png) [@adrisr](https://discuss.elastic.co/u/adrisr)\
**Post date:** [July 3, 2018, 5:55pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247/7 "2018-07-03T17:55:51Z")

</div>

The problem is here:

```auto
#fields:
  application: app1
# review: 1

```

In order for this to work you need to uncomment the fields line, like this:

```auto
fields:
  application: app1

```

Note that YaML format is very sensitive about whitespace and indentation, read [https://www.elastic.co/guide/en/beats/filebeat/current/yaml-tips.html](https://www.elastic.co/guide/en/beats/filebeat/current/yaml-tips.html)

---

<div class="post-metadata">

**Author:** ![eric\_Igbinosun](https://avatars.discourse-cdn.com/v4/letter/e/8baadc/32.png) [@eric\_Igbinosun](https://discuss.elastic.co/u/eric_Igbinosun)\
**Post date:** [July 4, 2018, 4:42pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247/8 "2018-07-04T16:42:27Z")

</div>

thank you

this was very helpful

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 1, 2018, 4:42pm UTC](https://discuss.elastic.co/t/filebeat-setup-error/138247/9 "2018-08-01T16:42:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
