# Filebeat setup issues on PC

**URL:** <https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [March 12, 2024, 4:49pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248 "2024-03-12T16:49:28Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![bk\_elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bk_elk/32/122470_2.png) [@bk\_elk](https://discuss.elastic.co/u/bk_elk)\
**Post date:** [March 12, 2024, 4:49pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/1 "2024-03-12T16:49:28Z")

</div>

Exiting: couldn't connect to any of the configured Elasticsearch hosts. Errors: [error connecting to Elasticsearch at [https://myendpoint.ex.com](https://myendpoint.ex.com)

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [March 12, 2024, 4:53pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/2 "2024-03-12T16:53:55Z")

</div>

Hi @bk_elk Welcome to the community.

Just posting an error message does not really help.

What version?

What is your filebeat.yml?

Please format your code with the `</>` button Select the text then press the button.

The error says, The credentials that were provided to elasticsearch were not correct.

I would go back and check that.

Also, you posted the full URL to your endpoint, which is generally not a good idea, so I edited that out.

Please be careful posting potentially sensitive information.

---

<div class="post-metadata">

**Author:** ![bk\_elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bk_elk/32/122470_2.png) [@bk\_elk](https://discuss.elastic.co/u/bk_elk)\
**Post date:** [March 12, 2024, 4:59pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/3 "2024-03-12T16:59:33Z")

</div>

Hello, Stephen i am new to this Elasticsearch. I am trying to send the application/server logs from the Windows server to the Elasticsearch using filebeat: I am supposed to use cloud.ioa nd cloud.auth. all my creds are good and works fine using it manual login. version is 7.17.16

---

<div class="post-metadata">

**Author:** ![bk\_elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bk_elk/32/122470_2.png) [@bk\_elk](https://discuss.elastic.co/u/bk_elk)\
**Post date:** [March 12, 2024, 5:03pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/4 "2024-03-12T17:03:16Z")

</div>

this is the approach i have:

output.elasticsearch:  
cloud.id: "your\_cloud\_id"  
cloud.auth: "your\_cloud\_auth"

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [March 12, 2024, 5:57pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/5 "2024-03-12T17:57:11Z")

</div>

run

`.\bin\filebeat.exe test output`

> [@bk\_elk](#):
>
> output.elasticsearch:  
> cloud.id: "your\_cloud\_id"  
> cloud.auth: "your\_cloud\_auth"

Most likely one of those is wrong

Cloud ID is not a URL...

 ![Screenshot 2024-03-12 at 10.55.22 AM](https://us1.discourse-cdn.com/elastic/original/3X/b/3/b39231a26b482541b7bf12bc44e5619b008cfe25.png)

`cloud.auth` is either

`username:password`

Or a properly formated API Key...

Which are you using...

---

<div class="post-metadata">

**Author:** ![bk\_elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bk_elk/32/122470_2.png) [@bk\_elk](https://discuss.elastic.co/u/bk_elk)\
**Post date:** [March 12, 2024, 6:05pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/6 "2024-03-12T18:05:03Z")

</div>

> [@stephenb](#):
>
> .\bin\filebeat.exe test output

I have well formatted API keys for cloud.id and cloud.auth. I verified those both keys are correct. When i ran the cmd you provided i get an error message. FYI! I'm working on Windows machine/server. I am able to install and run the filebeat successfully. The issues comes when i execute: .\filebeat.exe setup -e . This is where I'm kept getting the error. I also verified that i don't have any network issues.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [March 12, 2024, 8:10pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/7 "2024-03-12T20:10:49Z")

</div>

> [@bk\_elk](#):
>
> When i ran the cmd you provided i get an error message

What error message

And sorry command Should be

`.\filebeat.exe test output`

Always show the command and the output otherwise, we can't help

And what happens when you run

`.\filebeat.exe setup -e`

And are you following

> **[Filebeat quick start: installation and configuration | Filebeat Reference...](https://www.elastic.co/guide/en/beats/filebeat/7.17/filebeat-installation-configuration.html)**

---

<div class="post-metadata">

**Author:** ![bk\_elk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bk_elk/32/122470_2.png) [@bk\_elk](https://discuss.elastic.co/u/bk_elk)\
**Post date:** [March 13, 2024, 2:05pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/8 "2024-03-13T14:05:55Z")

</div>

> [@stephenb](#):
>
> .\filebeat.exe test output

Yes! I'm following the Elastic official page installation guidelines:  
When I ran

> .\filebeat.exe test output

Got the error message

> ERROR 401 Unauthorized but before errors : parse, connection, TLS is all ok.

And when I ran

> .\filebeat.exe setup -e I get this error: Exiting: couldn't connect to any of the configured Elasticsearch hosts.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [March 13, 2024, 2:22pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/9 "2024-03-13T14:22:59Z")

</div>

So that means you are not set up correctly with either the cloud.id or cloud.auth

Exactly How / where did you create the API Key ... there are 2 different places...

Perhaps check here

> [@ApiError AuthenticationException even correct API Key is provided](https://discuss.elastic.co/t/apierror-authenticationexception-even-correct-api-key-is-provided/353121/2):
>
> Hi @tfulanchan Welcome to the community. Kinda a common mistake when getting started. That creates An API Key for using The ESS / Elastic Cloud API to create and modify whole clusters. Etc. To work within an Elasticsearch cluster...I.e the REST API to load data and work inside an Elasticsearch cluster Go to Kibana - Stack Management - API Keys Make sure you get the correct format for the REST API

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 10, 2024, 2:23pm UTC](https://discuss.elastic.co/t/filebeat-setup-issues-on-pc/355248/10 "2024-04-10T14:23:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
