# Filebeat starting error

**URL:** <https://discuss.elastic.co/t/filebeat-starting-error/178570>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [April 26, 2019, 6:50am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570 "2019-04-26T06:50:52Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Amit\_Yadav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_yadav/32/45068_2.png) [@Amit\_Yadav](https://discuss.elastic.co/u/Amit_Yadav)\
**Post date:** [April 26, 2019, 6:50am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570/1 "2019-04-26T06:50:52Z")

</div>

Hi please suggest me when i starting the filebeat i m getting the below error .

filebeat.service - filebeat  
Loaded: loaded (/usr/lib/systemd/system/filebeat.service; enabled; vendor preset: disabled)  
Active: failed (Result: start-limit) since Fri 2019-04-26 12:13:09 IST; 3s ago  
Docs: [https://www.elastic.co/guide/en/beats/filebeat/current/index.html](https://www.elastic.co/guide/en/beats/filebeat/current/index.html)  
Process: 29450 ExecStart=/usr/bin/filebeat -c /etc/filebeat/filebeat.yml (code=exited, status=1/FAILURE)  
Main PID: 29450 (code=exited, status=1/FAILURE)

Apr 26 12:13:09 ip-172-31-23-198.ap-south-1.compute.internal systemd[1]: filebeat.service: main process exited, code=exited, status=1/FAILURE  
Apr 26 12:13:09 ip-172-31-23-198.ap-south-1.compute.internal systemd[1]: Unit filebeat.service entered failed state.  
Apr 26 12:13:09 ip-172-31-23-198.ap-south-1.compute.internal systemd[1]: filebeat.service failed.  
Apr 26 12:13:09 ip-172-31-23-198.ap-south-1.compute.internal systemd[1]: filebeat.service holdoff time over, scheduling restart.  
Apr 26 12:13:09 ip-172-31-23-198.ap-south-1.compute.internal systemd[1]: start request repeated too quickly for filebeat.service  
Apr 26 12:13:09 ip-172-31-23-198.ap-south-1.compute.internal systemd[1]: Failed to start filebeat.  
Apr 26 12:13:09 ip-172-31-23-198.ap-south-1.compute.internal systemd[1]: Unit filebeat.service entered failed state.  
Apr 26 12:13:09 ip-172-31-23-198.ap-south-1.compute.internal systemd[1]: filebeat.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

---

<div class="post-metadata">

**Author:** ![harshbajaj16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/harshbajaj16/32/44970_2.png) [@harshbajaj16](https://discuss.elastic.co/u/harshbajaj16)\
**Post date:** [April 26, 2019, 9:05am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570/2 "2019-04-26T09:05:31Z")

</div>

HI @Amit_Yadav,

Could you please paste your filebeat.yml file here.

Regards,  
Harsh Bajaj

---

<div class="post-metadata">

**Author:** ![Amit\_Yadav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_yadav/32/45068_2.png) [@Amit\_Yadav](https://discuss.elastic.co/u/Amit_Yadav)\
**Post date:** [April 26, 2019, 9:20am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570/3 "2019-04-26T09:20:26Z")

</div>

Please download the filebeat.yml file using below link

> **[filebeat.txt](https://drive.google.com/file/d/1MsJeKcOIBaYaaUZ5lryGZKLaWaa3T_g9/view?usp=drive_open)**
>
> Google Drive file.

---

<div class="post-metadata">

**Author:** ![harshbajaj16](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/harshbajaj16/32/44970_2.png) [@harshbajaj16](https://discuss.elastic.co/u/harshbajaj16)\
**Post date:** [April 26, 2019, 9:32am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570/4 "2019-04-26T09:32:57Z")

</div>

Hi,

Please check /var/log/messages while starting filebeat service and let me know the error which you getting.

Regards,  
Harsh Bajaj

---

<div class="post-metadata">

**Author:** ![Amit\_Yadav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_yadav/32/45068_2.png) [@Amit\_Yadav](https://discuss.elastic.co/u/Amit_Yadav)\
**Post date:** [April 26, 2019, 9:54am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570/5 "2019-04-26T09:54:26Z")

</div>

Apr 26 15:23:49 ip-172-31-23-198 filebeat: Error Initialising publisher: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:49 ip-172-31-23-198 systemd: filebeat.service: main process exited, code=exited, status=1/FAILURE  
Apr 26 15:23:49 ip-172-31-23-198 systemd: Unit filebeat.service entered failed state.  
Apr 26 15:23:49 ip-172-31-23-198 systemd: filebeat.service failed.  
Apr 26 15:23:49 ip-172-31-23-198 systemd: filebeat.service holdoff time over, scheduling restart.  
Apr 26 15:23:49 ip-172-31-23-198 systemd: Started filebeat.  
Apr 26 15:23:49 ip-172-31-23-198 systemd: Starting filebeat...  
Apr 26 15:23:49 ip-172-31-23-198 filebeat: Error Initialising publisher: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:49 ip-172-31-23-198 /usr/bin/filebeat[31208]: beat.go:161: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:49 ip-172-31-23-198 systemd: filebeat.service: main process exited, code=exited, status=1/FAILURE  
Apr 26 15:23:49 ip-172-31-23-198 systemd: Unit filebeat.service entered failed state.  
Apr 26 15:23:49 ip-172-31-23-198 systemd: filebeat.service failed.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service holdoff time over, scheduling restart.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Started filebeat.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Starting filebeat...  
Apr 26 15:23:50 ip-172-31-23-198 filebeat: Error Initialising publisher: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:50 ip-172-31-23-198 /usr/bin/filebeat[31214]: beat.go:161: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service: main process exited, code=exited, status=1/FAILURE  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Unit filebeat.service entered failed state.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service failed.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service holdoff time over, scheduling restart.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Started filebeat.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Starting filebeat...  
Apr 26 15:23:50 ip-172-31-23-198 filebeat: Error Initialising publisher: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:50 ip-172-31-23-198 /usr/bin/filebeat[31220]: beat.go:161: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service: main process exited, code=exited, status=1/FAILURE  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Unit filebeat.service entered failed state.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service failed.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service holdoff time over, scheduling restart.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Started filebeat.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Starting filebeat...  
Apr 26 15:23:50 ip-172-31-23-198 filebeat: Error Initialising publisher: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:50 ip-172-31-23-198 /usr/bin/filebeat[31226]: beat.go:161: No outputs are defined. Please define one under the output section.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service: main process exited, code=exited, status=1/FAILURE  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Unit filebeat.service entered failed state.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service failed.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service holdoff time over, scheduling restart.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: start request repeated too quickly for filebeat.service  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Failed to start filebeat.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: Unit filebeat.service entered failed state.  
Apr 26 15:23:50 ip-172-31-23-198 systemd: filebeat.service failed.

---

<div class="post-metadata">

**Author:** ![Amit\_Yadav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_yadav/32/45068_2.png) [@Amit\_Yadav](https://discuss.elastic.co/u/Amit_Yadav)\
**Post date:** [April 26, 2019, 10:39am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570/6 "2019-04-26T10:39:29Z")

</div>

filebeat is running now

but when i m hitting below curl in server side getting this

curl -XGET '[http://localhost:9200/filebeat-\*/\_search?pretty](http://localhost:9200/filebeat-*/_search?pretty)'  
{  
"took" : 1,  
"timed\_out" : false,  
"\_shards" : {  
"total" : 0,  
"successful" : 0,  
"failed" : 0  
},  
"hits" : {  
"total" : 0,  
"max\_score" : 0.0,  
"hits" :   
}  
}

---

<div class="post-metadata">

**Author:** ![Amit\_Yadav](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amit_yadav/32/45068_2.png) [@Amit\_Yadav](https://discuss.elastic.co/u/Amit_Yadav)\
**Post date:** [April 26, 2019, 10:43am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570/7 "2019-04-26T10:43:07Z")

</div>

My log type is this

log-lobby-1\_Apr-26-2019.out

in filebeat i m using like this

/home/logs/\*

please let me know what should i used in kibana gui to search index

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 24, 2019, 10:43am UTC](https://discuss.elastic.co/t/filebeat-starting-error/178570/8 "2019-05-24T10:43:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
