# Filebeat Stop Cleaning Registry

**URL:** <https://discuss.elastic.co/t/filebeat-stop-cleaning-registry/58902>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [August 25, 2016, 7:59am UTC](https://discuss.elastic.co/t/filebeat-stop-cleaning-registry/58902 "2016-08-25T07:59:40Z")\
**Posts on this page:** 1\
**Showing post:** 8

<div class="post-metadata">

**Author:** ![Gabry993](https://avatars.discourse-cdn.com/v4/letter/g/96bed5/32.png) [@Gabry993](https://discuss.elastic.co/u/Gabry993)\
**Post date:** [September 1, 2016, 7:00am UTC](https://discuss.elastic.co/t/filebeat-stop-cleaning-registry/58902/8 "2016-09-01T07:00:47Z")

</div>

Hi,  
the

> ERR File is falling under ignore\_older before harvesting is finished. Adjust your close\_\* settings: d:Logger\logxxx.log

still occurs during night, however we solved the problem with the growing registry: we have increased the --pipeline-batch-size in logstash and the flush\_size in the elastic output. Now everything seems ok during the day, but we found 2 type of error which I can't understand.  
We got many occurrences of:

> ERR Failed to publish events caused by: EOF  
> INFO Error publishing events (retrying): EOF

And:

> ERR Failed to publish events caused by: read tcp ip:1157-\>ip:port: i/o timeout

Are they serious problem? I can't understand it as log messages are correctly sent to logstash and elasticsearch.

---

_[View the full topic](https://discuss.elastic.co/t/filebeat-stop-cleaning-registry/58902)._
