# Filebeat stops harvesting files

**URL:** <https://discuss.elastic.co/t/filebeat-stops-harvesting-files/272190>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [May 5, 2021, 1:22pm UTC](https://discuss.elastic.co/t/filebeat-stops-harvesting-files/272190 "2021-05-05T13:22:40Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![boernd](https://avatars.discourse-cdn.com/v4/letter/b/3e96dc/32.png) [@boernd](https://discuss.elastic.co/u/boernd)\
**Post date:** [May 5, 2021, 1:22pm UTC](https://discuss.elastic.co/t/filebeat-stops-harvesting-files/272190/1 "2021-05-05T13:22:40Z")

</div>

Filebeat vesion: 7.10

Filebeat sometimes throws the following errors and stops harvesting a file:

```auto
Harvester could not be started on existing file: /var/lib/docker/containers/acaeae7d8182fc7c78a5066a178593640ce4fbc920b4f722e1c995ddcade8e61/acaeae7d8182fc7c78a5066a178593640ce4fbc920b4f722e1c995ddcade8e61-json.log, Err: registry already stopped
File cleanup state update error: input outlet closed

```

I'm using the filebeat autodiscover, example config:

```auto
filebeat.autodiscover:
  providers:
  - hints.enabled: false
    templates:
    - condition:
[...]
      config:
      - clean_removed: true
        fields:
[...]
        fields_under_root: true
        ignore_older: 10m
        paths:
        - /var/lib/docker/containers/${data.kubernetes.container.id}/*-json.log
        - /var/lib/docker/containers/${data.kubernetes.container.id}/*-json.log.*
        scan_frequency: 5s
        type: container

```

A pod restart resolves the issue. Any ideas? Should I open a Github issue?

Regards  
Bernd

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 2, 2021, 3:23pm UTC](https://discuss.elastic.co/t/filebeat-stops-harvesting-files/272190/2 "2021-06-02T15:23:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
