# Filebeat to logstash connect: no route to host

**URL:** <https://discuss.elastic.co/t/filebeat-to-logstash-connect-no-route-to-host/167002>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 4, 2019, 5:06pm UTC](https://discuss.elastic.co/t/filebeat-to-logstash-connect-no-route-to-host/167002 "2019-02-04T17:06:15Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![hsam](https://avatars.discourse-cdn.com/v4/letter/h/74df32/32.png) [@hsam](https://discuss.elastic.co/u/hsam)\
**Post date:** [February 4, 2019, 5:06pm UTC](https://discuss.elastic.co/t/filebeat-to-logstash-connect-no-route-to-host/167002/1 "2019-02-04T17:06:15Z")

</div>

Everything is up and running but filebeat cannot contact logstash which is on another machine  
logstash.conf  
input {  
beats {  
port =\> 5044  
}  
}

output {  
elasticsearch {  
hosts =\> ["[http://localhost:9200](http://localhost:9200)"]  
index =\> "%{m3beat-%{+YYYY.MM.dd}"  
}  
stdout { codec =\> rubydebug }  
}  
filebeat.yml  
output.logstash:

# The Logstash hosts

hosts: ["10.1.252.21:5044"]

I get the following error in filebeat log:  
48:25.719+0100 ERROR pipeline/output.go:100 Failed to connect to backoff(async(tcp://10.1.252.21:5044)): dial tcp 10.1.252.21:5044: connect: no route to host  
2019-02-04T17:48:25.719+0100 INFO pipeline/output.go:93 Attempting to reconnect to backoff(async(tcp://10.1.252.21:5044)) with 6 reconnect attempt(s)  
2019-02-04T17:48:25.719+0100 DEBUG [logstash] logstash/async.go:111 connect

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 4, 2019, 5:06pm UTC](https://discuss.elastic.co/t/filebeat-to-logstash-connect-no-route-to-host/167002/2 "2019-03-04T17:06:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
