# Filebeat unable to dial tcp on port logstash port 5044

**URL:** <https://discuss.elastic.co/t/filebeat-unable-to-dial-tcp-on-port-logstash-port-5044/126324>\
**Category:** Logstash\
**Created:** [March 31, 2018, 3:36pm UTC](https://discuss.elastic.co/t/filebeat-unable-to-dial-tcp-on-port-logstash-port-5044/126324 "2018-03-31T15:36:46Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Chandan\_Mishra](https://avatars.discourse-cdn.com/v4/letter/c/57b2e6/32.png) [@Chandan\_Mishra](https://discuss.elastic.co/u/Chandan_Mishra)\
**Post date:** [March 31, 2018, 3:36pm UTC](https://discuss.elastic.co/t/filebeat-unable-to-dial-tcp-on-port-logstash-port-5044/126324/1 "2018-03-31T15:36:46Z")

</div>

I am running logstash on remote Centos 6.8 machine. While sending logs via filebeat getting error

**ERROR pipeline/output.go:74 Failed to connect: dial tcp 192.168.180.72:5044: i/o timeout**

Tried telnet from filebeat server:  
telnet 192.168.180.72 5044  
But got connection refused error.

I tried telnet on the Logstash server also, and telnet was happening.  
telnet 192.168.180.72 5044  
Trying 192.168.180.72...  
Connected to 192.168.180.72.  
Escape character is '^]'.

Tried netstat on logstash server:  
netstat -anp | grep 5044  
tcp 0 0 0.0.0.0:5044 0.0.0.0:\* LISTEN 31861/java

Any idea how to troubleshoot this, am I missing anything?

---

<div class="post-metadata">

**Author:** ![yaauie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yaauie/32/23363_2.png) [@yaauie](https://discuss.elastic.co/u/yaauie)\
**Post date:** [March 31, 2018, 6:47pm UTC](https://discuss.elastic.co/t/filebeat-unable-to-dial-tcp-on-port-logstash-port-5044/126324/2 "2018-03-31T18:47:47Z")

</div>

192.168.x.x is a private range dedicated for use within a private network; are the two devices on the same network, and if so is there a route from one host to the other?

I typically use `ping` and `traceroute` to discover the answers to these questions.

---

<div class="post-metadata">

**Author:** ![Chandan\_Mishra](https://avatars.discourse-cdn.com/v4/letter/c/57b2e6/32.png) [@Chandan\_Mishra](https://discuss.elastic.co/u/Chandan_Mishra)\
**Post date:** [April 1, 2018, 3:16am UTC](https://discuss.elastic.co/t/filebeat-unable-to-dial-tcp-on-port-logstash-port-5044/126324/3 "2018-04-01T03:16:10Z")

</div>

Yeah, both the machines are in the same network, and both are able to ping each other.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 29, 2018, 3:17am UTC](https://discuss.elastic.co/t/filebeat-unable-to-dial-tcp-on-port-logstash-port-5044/126324/4 "2018-04-29T03:17:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
