# Filebeat version 6.3.\* (amd64), libbeat 6.3.\* unable to resolve DNS lookups for downstream hosts after restarting

**URL:** <https://discuss.elastic.co/t/filebeat-version-6-3-amd64-libbeat-6-3-unable-to-resolve-dns-lookups-for-downstream-hosts-after-restarting/165817>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [January 25, 2019, 7:11pm UTC](https://discuss.elastic.co/t/filebeat-version-6-3-amd64-libbeat-6-3-unable-to-resolve-dns-lookups-for-downstream-hosts-after-restarting/165817 "2019-01-25T19:11:28Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![esmith](https://avatars.discourse-cdn.com/v4/letter/e/f1d935/32.png) [@esmith](https://discuss.elastic.co/u/esmith)\
**Post date:** [January 25, 2019, 7:11pm UTC](https://discuss.elastic.co/t/filebeat-version-6-3-amd64-libbeat-6-3-unable-to-resolve-dns-lookups-for-downstream-hosts-after-restarting/165817/1 "2019-01-25T19:11:28Z")

</div>

Currently seeing an issue on linux hosts running filebeat 6.3.\* in which filebeat, if stopped and restarted for any reason, is no longer able to resolve dns lookups for downstream hosts such as elasticsearch, etc.

I am able to curl and dig these hosts just fine. filebeat logs look as follows:

filebeat shuts down:  
2019-01-25T04:31:48.461Z INFO [monitoring] log/log.go:133 Uptime: 10h31m3.934500227s  
2019-01-25T04:31:48.461Z INFO [monitoring] log/log.go:110 Stopping metrics logging.  
2019-01-25T04:31:48.461Z INFO instance/beat.go:321 filebeat stopped.

then filebeat comes back up:  
2019-01-25T04:31:48.707Z INFO log/harvester.go:228 Harvester started for file: /var/log/foo.log  
2019-01-25T04:31:48.711Z INFO log/harvester.go:228 Harvester started for file: /mnt/log/bar/bar.log  
2019-01-25T04:31:59.533Z WARN transport/tcp.go:36 DNS lookup failure "some-domain-1": lookup  
some-domain-1 on 127.0.0.1:53: read udp 127.0.0.1:40116-\>127.0.0.1:53: i/o timeout  
2019-01-25T04:32:00.533Z ERROR pipeline/output.go:74 Failed to connect: Get  
[https://some-domain-1](https://some-domain-1): lookup some-domain-1 on 127.0.0.1:53: read udp 127.0.0.1:40116-\>127.0.0.1:53: i/o timeout

I am running a local dnsmasq agent on each host running filebeat.

I attempted to substitute a binary built against libc to use the libc name-resolver instead of the pure go name-resolver but I get the same behavior.

Has anyone seen anything similar? Apologies for any typos, etc.

thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 22, 2019, 7:11pm UTC](https://discuss.elastic.co/t/filebeat-version-6-3-amd64-libbeat-6-3-unable-to-resolve-dns-lookups-for-downstream-hosts-after-restarting/165817/2 "2019-02-22T19:11:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
