# Filebeat won't start the service. Data path already locked by another beat

**URL:** <https://discuss.elastic.co/t/filebeat-wont-start-the-service-data-path-already-locked-by-another-beat/285989>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [October 6, 2021, 7:49am UTC](https://discuss.elastic.co/t/filebeat-wont-start-the-service-data-path-already-locked-by-another-beat/285989 "2021-10-06T07:49:44Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![dhody\_rhmd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dhody_rhmd/32/58823_2.png) [@dhody\_rhmd](https://discuss.elastic.co/u/dhody_rhmd)\
**Post date:** [October 6, 2021, 7:49am UTC](https://discuss.elastic.co/t/filebeat-wont-start-the-service-data-path-already-locked-by-another-beat/285989/1 "2021-10-06T07:49:44Z")

</div>

Hello, This is my first time to setup logging stack.

My problem is the Filebeat service wont start.

```auto
 filebeat.service - Filebeat sends log files to Logstash or directly to Elasticsearch.
   Loaded: loaded (/lib/systemd/system/filebeat.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2021-10-06 07:41:10 UTC; 3s ago
     Docs: https://www.elastic.co/beats/filebeat
  Process: 19354 ExecStart=/usr/share/filebeat/bin/filebeat --environment systemd $BEAT_LOG_OPTS $BEAT_CONFIG_OPTS $BEAT_PATH_OPTS (code=exited, status=1/FAILURE
 Main PID: 19354 (code=exited, status=1/FAILURE)

Oct 06 07:41:10 delete-soon systemd[1]: filebeat.service: Main process exited, code=exited, status=1/FAILURE
Oct 06 07:41:10 delete-soon systemd[1]: filebeat.service: Failed with result 'exit-code'.
Oct 06 07:41:10 delete-soon systemd[1]: filebeat.service: Service RestartSec=100ms expired, scheduling restart.
Oct 06 07:41:10 delete-soon systemd[1]: filebeat.service: Scheduled restart job, restart counter is at 5.
Oct 06 07:41:10 delete-soon systemd[1]: Stopped Filebeat sends log files to Logstash or directly to Elasticsearch..
Oct 06 07:41:10 delete-soon systemd[1]: filebeat.service: Start request repeated too quickly.
Oct 06 07:41:10 delete-soon systemd[1]: filebeat.service: Failed with result 'exit-code'.
Oct 06 07:41:10 delete-soon systemd[1]: Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch..

```

Filebeat log produces

```auto
Exiting: data path already locked by another beat. Please make sure that multiple beats are not sharing the same data path (path.data).

```

I'm looking around for answer but seems didn't worked. What I have to do to solve this?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 3, 2021, 9:50am UTC](https://discuss.elastic.co/t/filebeat-wont-start-the-service-data-path-already-locked-by-another-beat/285989/2 "2021-11-03T09:50:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
