# Filebeat works but keeps generating ERROR Messages in Logs

**URL:** <https://discuss.elastic.co/t/filebeat-works-but-keeps-generating-error-messages-in-logs/221396>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 28, 2020, 9:44am UTC](https://discuss.elastic.co/t/filebeat-works-but-keeps-generating-error-messages-in-logs/221396 "2020-02-28T09:44:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lukas\_L](https://avatars.discourse-cdn.com/v4/letter/l/7ba0ec/32.png) [@Lukas\_L](https://discuss.elastic.co/u/Lukas_L)\
**Post date:** [February 28, 2020, 9:44am UTC](https://discuss.elastic.co/t/filebeat-works-but-keeps-generating-error-messages-in-logs/221396/1 "2020-02-28T09:44:28Z")

</div>

Hi there,

I am running Filebeat (7.3.1) on multiple Systems and all of them are sending their data to Logstash (Elasticsearch) as desired. I can see the events in Kibana perfectly.  
But I realized that every Filebeat instance keeps writing Error messages in their own logfiles like:

> 2020-02-28T10:13:55.354+0100 ERROR logstash/async.go:256 Failed to publish events caused by: write tcp 10.193.196.86:45350-\>10.193.196.93:5044: write: connection reset by peer  
> 2020-02-28T10:13:57.008+0100 ERROR pipeline/output.go:121 Failed to publish events: write tcp 10.193.196.86:45350-\>10.193.196.93:5044: write: connection reset by peer

This is happening every time they try to send an event to Logstash (which like I said actually works).

I am running two Elasticsearch/ Logstash Nodes and one seperate Kibana Node. (All on 7.3.1)

My Logstash input config looks like this:

> input {  
> beats {  
> port =\> 5044  
> client\_inactivity\_timeout =\> 3000  
> }  
> }
> 
> output {  
> if ![type] {  
> pipeline { send\_to =\> "default" }  
> }  
> else if ( [type] == 'testpipe' ) {  
> pipeline { send\_to =\> 'testpipe' }  
> }  
> ......

The ouput part continues with multiple pipeline redirections depending on the custom 'type' field.

My Filebeat ouput:

> output.logstash:  
> hosts: ["lSnode1:5044", "lSnode2:5044"]  
> loadbalance: true

What I have tried so far:

- update the logstash-beats-input plugin to the newest version
- add 'client\_inactivity\_timeout =\> 3000' to my LS pipe

...but neither does seem to work for me.

I am open for any ideas.  
If you need any more information just ask.

---

<div class="post-metadata">

**Author:** ![ahmed\_charafouddine](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ahmed_charafouddine/32/45129_2.png) [@ahmed\_charafouddine](https://discuss.elastic.co/u/ahmed_charafouddine)\
**Post date:** [February 28, 2020, 10:06am UTC](https://discuss.elastic.co/t/filebeat-works-but-keeps-generating-error-messages-in-logs/221396/2 "2020-02-28T10:06:47Z")

</div>

tcp flows are well open between these two machines:` 10.193.196.86:45350->10.193.196.93:5044` ?

---

<div class="post-metadata">

**Author:** ![Lukas\_L](https://avatars.discourse-cdn.com/v4/letter/l/7ba0ec/32.png) [@Lukas\_L](https://discuss.elastic.co/u/Lukas_L)\
**Post date:** [February 28, 2020, 10:38am UTC](https://discuss.elastic.co/t/filebeat-works-but-keeps-generating-error-messages-in-logs/221396/3 "2020-02-28T10:38:05Z")

</div>

Yes.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 27, 2020, 10:38am UTC](https://discuss.elastic.co/t/filebeat-works-but-keeps-generating-error-messages-in-logs/221396/4 "2020-03-27T10:38:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
