# Filed to execute main query

**URL:** https://discuss.elastic.co/t/filed-to-execute-main-query/41738
**Category:** Elasticsearch
**Created:** [February 15, 2016, 6:26am UTC](https://discuss.elastic.co/t/filed-to-execute-main-query/41738 "2016-02-15T06:26:36Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![moni15moni](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moni15moni/32/42311_2.png) [@moni15moni](https://discuss.elastic.co/u/moni15moni)
#### Post date: [February 15, 2016, 6:26am UTC](https://discuss.elastic.co/t/filed-to-execute-main-query/41738/1 "2016-02-15T06:26:36Z")

</div>

I have faced a issue in searching,I am continuously getting out of memory in the particular index.

Caused by: java.lang.OutOfMemoryError: Java heap space  
[2016-02-15 06:18:08,400][DEBUG][action.search.type] [10.1.0.31] All shards failed for phase: [query\_fetch]  
org.elasticsearch.transport.RemoteTransportException: [10.1.0.31][inet[/10.1.0.37:9300]][indices:data/read/search[phase/query+fetch]]  
Caused by: org.elasticsearch.search.query.QueryPhaseExecutionException: [unknown][0]: query[ConstantScore(+cache(first\_occurance:[1455476225000 TO 1455476230999]))],from[0],size[10],sort[\<custom:"first\_occurance": org.elasticsearch.index.fielddata.fieldcomparator.LongValuesComparatorSource@4c0e352d\>!]: Query Failed [Failed to execute main query]

In the above exception i am getting ,when i tried to execute the ascending order,But if there is no soting i am not getting the exception,Eventhough my search criteria is matched with only 10 records also it won't execute.

Thanks  
Moni

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 15, 2016, 6:40pm UTC](https://discuss.elastic.co/t/filed-to-execute-main-query/41738/2 "2016-02-15T18:40:28Z")

</div>

What does the query look like?

---

<div class="post-metadata">

### Author: ![moni15moni](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/moni15moni/32/42311_2.png) [@moni15moni](https://discuss.elastic.co/u/moni15moni)
#### Post date: [February 16, 2016, 5:12am UTC](https://discuss.elastic.co/t/filed-to-execute-main-query/41738/3 "2016-02-16T05:12:23Z")

</div>

Hi Mark ,

I found the problem in index mappings , I have missed the "fielddata": {"format": "doc\_values"} in mappings for that particular [column.So](http://column.So) when i have aggregated the particular field it will load everything on memory instead of [disk.So](http://disk.So) i am getting that exception continuously.

Thanks for you immediate attention.

Thanks  
Moni

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 11:16pm UTC](https://discuss.elastic.co/t/filed-to-execute-main-query/41738/4 "2017-07-05T23:16:10Z")

</div>


