# FileMaker jdbc input error

**URL:** <https://discuss.elastic.co/t/filemaker-jdbc-input-error/120599>\
**Category:** Logstash\
**Created:** [February 20, 2018, 10:00am UTC](https://discuss.elastic.co/t/filemaker-jdbc-input-error/120599 "2018-02-20T10:00:54Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rami.Atieyeh](https://avatars.discourse-cdn.com/v4/letter/r/41988e/32.png) [@Rami.Atieyeh](https://discuss.elastic.co/u/Rami.Atieyeh)\
**Post date:** [February 20, 2018, 10:00am UTC](https://discuss.elastic.co/t/filemaker-jdbc-input-error/120599/1 "2018-02-20T10:00:55Z")

</div>

Hi  
I am running Logstash with FileMaker JDBC connection as the input.  
Here is the config file I am using:  
input {  
jdbc {  
jdbc\_driver\_library =\> "C:\fmjdbc.jar"  
jdbc\_driver\_class =\> "com.filemaker.jdbc.Driver"  
jdbc\_connection\_string =\> "jdbc:filemaker://SERVER/DATABASE"  
jdbc\_user =\> "Username"  
jdbc\_password =\> "Password"  
schedule =\> "\* \* \* \* \*"  
statement =\> "SELECT \* FROM Table\_Name;"  
}  
}  
output {  
elasticsearch {  
hosts =\> ["localhost:9200"]  
index =\> "My\_Index"  
}  
stdout { codec =\> json }  
}

I am getting the following error:  
Unable to connect to database. Tried 1 times {:error\_message=\>"Java::JavaSql::SQLException: No suitable driver found for jdbc:filemaker://SERVER/DATABASE"}  
{ 2010 rufus-scheduler intercepted an error:  
2010 job:  
2010 Rufus::Scheduler::CronJob "\* \* \* \* \*" {}  
2010 error:  
2010 2010  
2010 Sequel::DatabaseConnectionError  
2010 Java::JavaSql::SQLException: No suitable driver found for jdbc:filemaker://SERVER/DATABASE  
2010 java.sql.DriverManager.getConnection(java/sql/DriverManager.java:689)  
2010 java.sql.DriverManager.getConnection(java/sql/DriverManager.java:247)  
2010 java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:498)  
2010 org.jruby.javasupport.JavaMethod.invokeDirectWithExceptionHandling(org/jruby/javasupport/JavaMethod.java:423)  
2010 org.jruby.javasupport.JavaMethod.invokeStaticDirect(org/jruby/javasupport/JavaMethod.java:355)

I tried to connect to FileMaker with DbVisualizer, by providing the same .jar file and driver class name and it worked.  
Can you please help?

---

<div class="post-metadata">

**Author:** ![Rami.Atieyeh](https://avatars.discourse-cdn.com/v4/letter/r/41988e/32.png) [@Rami.Atieyeh](https://discuss.elastic.co/u/Rami.Atieyeh)\
**Post date:** [February 23, 2018, 1:21pm UTC](https://discuss.elastic.co/t/filemaker-jdbc-input-error/120599/2 "2018-02-23T13:21:54Z")

</div>

Solved

> [@Logstash JDBC input - no suitable driver](https://discuss.elastic.co/t/logstash-jdbc-input-no-suitable-driver/120701/3):
>
> Hi Rami I have found the issue for Progress but may be applicable to yours. If you are using a type 4 jdbc driver - put the jar file into the logstash-core/libs/jar/... Folder. It seems to ignor in the core loading it - however you still need the entry to point to a valid file. This then registered the driver and I was able to move on. thanks Kevin

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 23, 2018, 1:21pm UTC](https://discuss.elastic.co/t/filemaker-jdbc-input-error/120599/3 "2018-03-23T13:21:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
