# Filter the Error content from Server Log (WildFly Application server log)

**URL:** <https://discuss.elastic.co/t/filter-the-error-content-from-server-log-wildfly-application-server-log/180486>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [May 10, 2019, 5:45am UTC](https://discuss.elastic.co/t/filter-the-error-content-from-server-log-wildfly-application-server-log/180486 "2019-05-10T05:45:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Madhan\_Kumar1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/madhan_kumar1/32/45920_2.png) [@Madhan\_Kumar1](https://discuss.elastic.co/u/Madhan_Kumar1)\
**Post date:** [May 10, 2019, 5:45am UTC](https://discuss.elastic.co/t/filter-the-error-content-from-server-log-wildfly-application-server-log/180486/1 "2019-05-10T05:45:28Z")

</div>

Hi Team,  
I've installed File Beat/Elasticsearch/Kibana to get server log from WildFly server and below is my configuration on File Beat  
We are using processor to filter the log content in File Beat  
###################### Filebeat Configuration Example #########################

- type: log
# Change to true to enable this input configuration.
enabled: true
# Paths that should be crawled and fetched. Glob based paths.
paths:
  - /home/lrpv2/svm-jsf-wildfly-1.0/standalone/log/server\*  
#- c:\programdata\elasticsearch\logs\*

# Exclude lines. A list of regular expressions to match. It drops the lines that are

# matching any regular expression from the list.
#exclude\_lines: ['^INFO']
# Include lines. A list of regular expressions to match. It exports the lines that are

# matching any regular expression from the list.
#include\_lines: ['^ERR', '^WARN']
# Exclude files. A list of regular expressions to match. Filebeat drops the files that

# are matching any regular expression from the list. By default, no files are dropped.
#exclude\_files: ['.gz$']
# Optional additional fields. These fields can be freely picked

# to add additional information to the crawled log files for filtering
#fields:
# level: debug

# review: 1

### Multiline options

# Multiline can be used for log messages spanning multiple lines. This is common

# for Java Stack Traces or C-Line Continuation

# The regexp Pattern that has to be matched. The example pattern matches all lines starting with [
multiline.pattern: "^[[:digit:]]{4}-[[:digit:]]{2}-[[:digit:]]{2} [[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2},[[:digit:]]{3}"
# Defines if the pattern set under pattern should be negated or not. Default is false.
multiline.negate: true
# Match can be set to "after" or "before". It is used to define if lines should be append to a pattern

# that was (not) matched before or after or as long as a pattern is not matched based on negate.

# Note: After is the equivalent to previous and before is the equivalent to to next in Logstash
multiline.match: after  
#============================= Filebeat modules ===============================  
filebeat.config.modules:
# Glob pattern for configuration loading
path: ${path.config}/modules.d/\*.yml
# Set to true to enable config reloading
reload.enabled: false
# Period on which files under path should be checked for changes
#reload.period: 10s  
#==================== Elasticsearch template setting ==========================  
#setup.template.settings:

# index.number\_of\_shards: 1

#index.codec: best\_compression  
#\_source.enabled: false  
setup.template.enabled: true  
setup.template.name: "lrptest-%{+yyyy.MM.dd}"  
setup.template.pattern: "lrptest-\*"  
setup.template.fields: "${path.config}/wf-fields.yml"  
setup.template.overwrite: true  
#============================== Dashboards =====================================

# These settings control loading the sample dashboards to the Kibana index. Loading

# the dashboards is disabled by default and can be enabled either by setting the

# options here or by using the `setup` command.

#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL

# has a value which is computed based on the Beat name and version. For released

# versions, this URL points to the dashboard archive on the [artifacts.elastic.co](http://artifacts.elastic.co)

# website.

#setup.dashboards.url:  
#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.

# This requires a Kibana endpoint configuration.

setup.kibana:

# Kibana Host

# Scheme and port can be left out and will be set to the default (http and 5601)

# In case you specify and additional path, the scheme is required: [http://localhost:5601/path](http://localhost:5601/path)

# IPv6 addresses should always be defined as: https://[2001:db8::1]:5601

host: "IP:5601"

# Kibana Space ID

# ID of the Kibana Space into which the dashboards should be loaded. By default,

# the Default Space will be used.

#space.id:  
#============================= Elastic Cloud ==================================

# These settings simplify using filebeat with the Elastic Cloud ([https://cloud.elastic.co/](https://cloud.elastic.co/)).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and

# `setup.kibana.host` options.

# You can find the `cloud.id` in the Elastic Cloud web UI.

#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and

# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.

#cloud.auth:  
#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------  
output.elasticsearch:

# Array of hosts to connect to.

hosts: ["IP:9200"]  
pipeline: "wildfly-pipeline"  
index: "lrptest-%{+yyyy.MM.dd}"

# Optional protocol and basic auth credentials.

#protocol: "https"  
#username: "elastic"  
#password: "changeme"  
#----------------------------- Logstash output --------------------------------  
#output.logstash:

# The Logstash hosts

#hosts: ["localhost:5044"]

# Optional SSL. By default is off.

# List of root certificates for HTTPS server verifications

#ssl.certificate\_authorities: ["/etc/pki/root/ca.pem"]

# Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

# Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"  
#================================ Processors =====================================

# Configure processors to enhance or manipulate events generated by the beat.

#processors:

# - add\_host\_metadata: ~

# - add\_cloud\_metadata: ~

processors:

- drop\_event:  
when:  
regexp:  
system.process.name: "ERROR"  
#================================ Logging =====================================

# Sets log level. The default log level is info.

# Available log levels are: error, warning, info, debug

#logging.level: debug

# At debug level, you can selectively enable logging only for some components.

# To enable all selectors use ["\*"]. Examples of other selectors are "beat",

# "publish", "service".

#logging.selectors: ["\*"]  
#================================= Migration ==================================

# This allows to enable 6.7 migration aliases

#migration.6\_to\_7.enabled: true

Expected Output: In Kibana system should display only ERROR content instead of all other contents .  
Above changes are not working as expected

---

<div class="post-metadata">

**Author:** ![Madhan\_Kumar1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/madhan_kumar1/32/45920_2.png) [@Madhan\_Kumar1](https://discuss.elastic.co/u/Madhan_Kumar1)\
**Post date:** [May 13, 2019, 7:05am UTC](https://discuss.elastic.co/t/filter-the-error-content-from-server-log-wildfly-application-server-log/180486/2 "2019-05-13T07:05:21Z")

</div>

HI,

Pls update anyone.

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [May 14, 2019, 2:05pm UTC](https://discuss.elastic.co/t/filter-the-error-content-from-server-log-wildfly-application-server-log/180486/3 "2019-05-14T14:05:01Z")

</div>

Please format configs and logs using the `</>`-Button in the editor.

Do you have some sample logs as well?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 11, 2019, 2:05pm UTC](https://discuss.elastic.co/t/filter-the-error-content-from-server-log-wildfly-application-server-log/180486/4 "2019-06-11T14:05:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
