# Fixed: Cannot yum install Filebeat, broken repo

**URL:** <https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675>\
**Category:** Beats\
**Created:** [February 25, 2016, 7:39am UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675 "2016-02-25T07:39:03Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [February 25, 2016, 7:39am UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/1 "2016-02-25T07:39:03Z")

</div>

Hi,

I try to yum install filebeat but I think the repo is not working. The repo I'm using is

```
[beats]
name=Elastic Beats Repository
baseurl=https://packages.elastic.co/beats/yum/el/$basearch
enabled=1
gpgkey=https://packages.elastic.co/GPG-KEY-elasticsearch
gpgcheck=1

```

Below is my error

```
Loaded plugins: fastestmirror, langpacks
base | 3.6 kB 00:00:00     
https://packages.elastic.co/beats/yum/el/x86_64/repodata/repomd.xml: [Errno 14] curl#77 - "Problem with the SSL CA cert (path? access rights?)"
Trying other mirror.

 One of the configured repositories failed (Elastic Beats Repository),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable beats

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=beats.skip_if_unavailable=true

failure: repodata/repomd.xml from beats: [Errno 256] No more mirrors to try.
https://packages.elastic.co/beats/yum/el/x86_64/repodata/repomd.xml: [Errno 14] curl#77 - "Problem with the SSL CA cert (path? access rights?)"

```

Can someone please check out this repo.

Thank you.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 25, 2016, 11:16pm UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/2 "2016-02-25T23:16:29Z")

</div>

Did you follow these instructions to set it up? [https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-installation.html#rpm](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-installation.html#rpm)

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [February 25, 2016, 11:35pm UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/3 "2016-02-25T23:35:56Z")

</div>

I got a report from a user at ElasticON that there was an issue, but I haven't yet looked into it.

---

<div class="post-metadata">

**Author:** ![fadzhli](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@fadzhli](https://discuss.elastic.co/u/fadzhli)\
**Post date:** [February 26, 2016, 3:30am UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/4 "2016-02-26T03:30:54Z")

</div>

No, I'm using these instruction because I want to use yum (more easier to update to new version). [https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-installation.html#rpm](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-installation.html#rpm)

I think the problem is with the repo.

Thank you

---

<div class="post-metadata">

**Author:** ![Martin\_Emrich](https://avatars.discourse-cdn.com/v4/letter/m/90db22/32.png) [@Martin\_Emrich](https://discuss.elastic.co/u/Martin_Emrich)\
**Post date:** [February 8, 2017, 4:06pm UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/5 "2017-02-08T16:06:46Z")

</div>

Hi!

Any news on this? I also try to install via yum, based on this documentation: [https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html)

But I get a 404 on [https://artifacts.elastic.co/packages/5.2/yum/repodata/repomd.xml](https://artifacts.elastic.co/packages/5.2/yum/repodata/repomd.xml).

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [February 8, 2017, 8:04pm UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/6 "2017-02-08T20:04:50Z")

</div>

The guide uses `5.x` not `5.2`.

This works [https://artifacts.elastic.co/packages/5.x/yum/repodata/repomd.xml](https://artifacts.elastic.co/packages/5.x/yum/repodata/repomd.xml)

---

<div class="post-metadata">

**Author:** ![Becky\_Jones](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/becky_jones/32/15837_2.png) [@Becky\_Jones](https://discuss.elastic.co/u/Becky_Jones)\
**Post date:** [February 24, 2017, 11:39am UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/7 "2017-02-24T11:39:43Z")

</div>

Hi, I'm having this issue too.

I have changed my repo to [https://artifacts.elastic.co/packages/5.x/yum](https://artifacts.elastic.co/packages/5.x/yum) as it states in the guide but I get the following error:

yum -y install filebeat  
Loaded plugins: fastestmirror  
Loading mirror speeds from cached hostfile

- base: [mirror.econdc.com](http://mirror.econdc.com)
- epel: [www.mirrorservice.org](http://www.mirrorservice.org)
- extras: [mirror.sov.uk.goscomb.net](http://mirror.sov.uk.goscomb.net)
- updates: [mirror.econdc.com](http://mirror.econdc.com)  
[https://artifacts.elastic.co/packages/5.x/yum/repodata/402cfc16d2e2b570dfe934ab10d618880a065da459d0539090bdfb87405972f9-primary.sqlite.bz2:](https://artifacts.elastic.co/packages/5.x/yum/repodata/402cfc16d2e2b570dfe934ab10d618880a065da459d0539090bdfb87405972f9-primary.sqlite.bz2:) [Errno 14] HTTP Error 404: Not Found  
Trying other mirror.  
Error: failure: repodata/402cfc16d2e2b570dfe934ab10d618880a065da459d0539090bdfb87405972f9-primary.sqlite.bz2 from beats: [Errno 256] No more mirrors to try.

I am a beginner so I'm not quite sure where I am going wrong.

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [February 24, 2017, 3:16pm UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/8 "2017-02-24T15:16:39Z")

</div>

I just tested installing Filebeat from the yum repo on a clean machine and it worked. Could you try it again?

Try clearing any cached metadata too.

`$ yum clean all`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 9:49pm UTC](https://discuss.elastic.co/t/fixed-cannot-yum-install-filebeat-broken-repo/42675/9 "2017-07-05T21:49:56Z")

</div>


