# FIXED: Mapping Error: \[\_index\] can not be changed to \[string\]

**URL:** <https://discuss.elastic.co/t/fixed-mapping-error--index-can-not-be-changed-to-string/50121>\
**Category:** Elasticsearch\
**Created:** [May 16, 2016, 1:33pm UTC](https://discuss.elastic.co/t/fixed-mapping-error--index-can-not-be-changed-to-string/50121 "2016-05-16T13:33:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mako7c4](https://avatars.discourse-cdn.com/v4/letter/m/cdc98d/32.png) [@mako7c4](https://discuss.elastic.co/u/mako7c4)\
**Post date:** [May 16, 2016, 1:33pm UTC](https://discuss.elastic.co/t/fixed-mapping-error--index-can-not-be-changed-to-string/50121/1 "2016-05-16T13:33:14Z")

</div>

Turns out a user was updating documents with a new field "\_index" and was causing all of the issues.  
It is odd elasticsearch will allow documents to be updated with fields like \_index and \_id....

#mods you can remove this post

----OLD-----

I'm getting the following error and I'm having trouble understanding how a metadata field like [\_index] can have this problem and how I can fix it. I've had this problem before, but with my custom fields so I could easily change my mapping and re-ingest the data to fix the issues. I tried to edit my mapping for \_index but that promptly failed as the [\_index] field can not be changed...

Error:  
message [failed to update mappings], failure [IllegalArgumentException[Mapper for [\_index] conflicts with existing mapping in other types:  
[mapper [\_index] cannot be changed from type [\_index] to [string]

OS: Centos7  
ES version: 2.1.2

Any help would be greatly appreciated.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 17, 2016, 2:55pm UTC](https://discuss.elastic.co/t/fixed-mapping-error--index-can-not-be-changed-to-string/50121/2 "2016-05-17T14:55:44Z")

</div>

> [@mako7c4](#):
>
> mods you can remove this post

We'll leave it, it might help someone in future.  
So thanks for updating it with your resolution! 😃

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:51pm UTC](https://discuss.elastic.co/t/fixed-mapping-error--index-can-not-be-changed-to-string/50121/3 "2017-07-05T22:51:01Z")

</div>


