# Fleet 0.0.0.0 address after Elastic Agent install

**URL:** https://discuss.elastic.co/t/fleet-0-0-0-0-address-after-elastic-agent-install/265698
**Category:** Endpoint Security
**Tags:** elastic-stack-security, fleet
**Created:** [February 27, 2021, 5:48pm UTC](https://discuss.elastic.co/t/fleet-0-0-0-0-address-after-elastic-agent-install/265698 "2021-02-27T17:48:02Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Cosmin\_Ciobanu1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cosmin_ciobanu1/32/78785_2.png) [@Cosmin\_Ciobanu1](https://discuss.elastic.co/u/Cosmin_Ciobanu1)
#### Post date: [February 27, 2021, 5:48pm UTC](https://discuss.elastic.co/t/fleet-0-0-0-0-address-after-elastic-agent-install/265698/1 "2021-02-27T17:48:02Z")

</div>

Hi!  
I've installed Elastci Agent with 10.10.10.19 address for both Kibana and Elasticsearch.  
However, after is starts I get this error "fail to checkin to fleet: Post "[https://0.0.0.0:5601/api/fleet/agents/ID/checkin?":](https://0.0.0.0:5601/api/fleet/agents/ID/checkin?%22:) dial tcp 0.0.0.0:5601: connectex: No connection could be made because the target machine actively refused it.".  
I don't understand from where is configured fleet.yml file because after every restart it is created and I cannot change the address in it.

Thank you!

---

<div class="post-metadata">

### Author: ![finbarr996](https://avatars.discourse-cdn.com/v4/letter/f/db5fbb/32.png) [@finbarr996](https://discuss.elastic.co/u/finbarr996)
#### Post date: [February 28, 2021, 1:37pm UTC](https://discuss.elastic.co/t/fleet-0-0-0-0-address-after-elastic-agent-install/265698/2 "2021-02-28T13:37:58Z")

</div>

Not sure if this will solve your current problem, but in the Agents screen in Fleet, in the top right hand corner there is a settings cog, click that and make sure the address and port of your elasticsearch and kibana server(s) is defined. I think that's where Fleet will pull this data from, but I may be wrong!

---

<div class="post-metadata">

### Author: ![mostlyjason](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mostlyjason/32/60849_2.png) [@mostlyjason](https://discuss.elastic.co/u/mostlyjason)
#### Post date: [March 2, 2021, 7:35pm UTC](https://discuss.elastic.co/t/fleet-0-0-0-0-address-after-elastic-agent-install/265698/3 "2021-03-02T19:35:55Z")

</div>

Hey Cosmin are you enrolling your agent into Fleet for the first time, or has it already connected successfully?

For agents enrolled into Fleet, it is defined in the settings that John mentioned. The agent policy includes the list of kibana URLs, which Fleet sends to the agents after they enroll. If you run on cloud the kibana URL will be set automatically. For self-managed clusters you have to set the URL yourself. See how to set the URL here [Quick start: Get logs and metrics into the Elastic Stack | Fleet User Guide [7.11] | Elastic](https://www.elastic.co/guide/en/fleet/current/fleet-quick-start.html)

---

<div class="post-metadata">

### Author: ![Cosmin\_Ciobanu1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cosmin_ciobanu1/32/78785_2.png) [@Cosmin\_Ciobanu1](https://discuss.elastic.co/u/Cosmin_Ciobanu1)
#### Post date: [March 3, 2021, 2:48pm UTC](https://discuss.elastic.co/t/fleet-0-0-0-0-address-after-elastic-agent-install/265698/4 "2021-03-03T14:48:06Z")

</div>

OK! I've resolved this problem. Thank you!  
But now after 2/3 minutes agent goes offline and I'm not receiving any log in this time.  
Any troubleshoot?

---

<div class="post-metadata">

### Author: ![Cosmin\_Ciobanu1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cosmin_ciobanu1/32/78785_2.png) [@Cosmin\_Ciobanu1](https://discuss.elastic.co/u/Cosmin_Ciobanu1)
#### Post date: [March 3, 2021, 7:46pm UTC](https://discuss.elastic.co/t/fleet-0-0-0-0-address-after-elastic-agent-install/265698/5 "2021-03-03T19:46:22Z")

</div>

This is the error mainly "message: Application: metricbeat--7.11.1[e9e46cd0-792e-11eb-8062-9be23ea21776]: State changed to FAILED: 1 error: 1 error: Error creating runner from config: 1 error: metricset 'system/load' not found"

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 31, 2021, 7:46pm UTC](https://discuss.elastic.co/t/fleet-0-0-0-0-address-after-elastic-agent-install/265698/6 "2021-03-31T19:46:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
